Search found 14 matches

by StatikPulse
02 Dec 2017 17:17
Forum: Discussions in English
Topic: z-way-server does not start in Stretch
Replies: 37
Views: 12309

Re: z-way-server does not start in Stretch

Glad I found this thread. I was struggling to figure out why it wasn't working.
by StatikPulse
28 May 2014 20:41
Forum: RaZberry
Topic: Steps to starting over
Replies: 1
Views: 915

Steps to starting over

Let's say I want to start over from scratch (rebuild the Raspberry Pi, reinstall the Razberry, new configuration ,etc)... are there any steps I should take before to make sure I don't run into any issues when I rebuild everything?
by StatikPulse
06 May 2014 18:07
Forum: RaZberry
Topic: Device not showing in automation engine
Replies: 2
Views: 1496

Re: Device not showing in automation engine

Finally following up. Your are correct, the latest pull has brought it back. Thanks!
by StatikPulse
10 Apr 2014 15:57
Forum: RaZberry
Topic: Device not showing in automation engine
Replies: 2
Views: 1496

Device not showing in automation engine

So I had to rebuild my Raspberry Pi. Everything was setup and working properly before I rebuilt it. The device (a multi level switch) was showing up in the UI and also was also returned by the Automation engine when calling /ZAutomation/api/v1/devices. After the Pi rebuild (and reinstall of Razberry...
by StatikPulse
10 Apr 2014 15:45
Forum: RaZberry
Topic: Setup modules from app
Replies: 4
Views: 1771

Re: Setup modules from app

If that's all you are looking to do, you app is probably what should be driving that and not a module. Have your app trigger an API call to the automation engine to turn the light on or off when it hits the time you specify in your app.
by StatikPulse
09 Apr 2014 18:30
Forum: RaZberry
Topic: List of possible events for device
Replies: 4
Views: 1689

Re: List of possible events for device

As mentioned, the switch I'm using does support Instant Status (which is what the Lutron patent is for) so it does/should report it's status when manually triggered.
by StatikPulse
09 Apr 2014 18:27
Forum: RaZberry
Topic: Setup modules from app
Replies: 4
Views: 1771

Re: Setup modules from app

I'm not sure if there's a simpler way around it, but what if you create a simple API for the module to communicate with? I'm not sure if modules can reside outside of the modules folder.
by StatikPulse
04 Apr 2014 14:48
Forum: RaZberry
Topic: Prevent log size
Replies: 2
Views: 1211

Re: Prevent log size

You best bet is to probably to use Logrotate. http://www.thegeekstuff.com/tag/debian-logrotate/
by StatikPulse
04 Apr 2014 14:26
Forum: RaZberry
Topic: Creating virtual devices in new automation
Replies: 19
Views: 11013

Re: problems with new automation

Could you post your whole code? I'm new to this and also playing with triggering events, but I'll help out if I can.
by StatikPulse
03 Apr 2014 03:25
Forum: RaZberry
Topic: List of possible events for device
Replies: 4
Views: 1689

Re: List of possible events for device

Looks like I was able to capture everything using:

Code: Select all

this.controller.onAny
Looks like events are set when the device is manually triggered? I have a Leviton VRI06 switch that supports instant status. Any advice on how to capture a manual toggle?