Search found 72 matches

by ridewithstyle
03 Jul 2019 10:53
Forum: RaZberry
Topic: Z-Way to MQTT
Replies: 28
Views: 25349

Re: Z-Way to MQTT

Hi there, I ran into the same problem, it was caused by more than one instance of the zway-mqtt module and non-unique ClientIDs. Once you add a second instance and keep the ClientID (which easily happens when you "duplicate" the running instance) mosquitto gets bombed with disconnect and reconnect m...
by ridewithstyle
02 Jul 2019 23:59
Forum: Discussions in English
Topic: MQTT Subscriber
Replies: 5
Views: 2341

Re: MQTT Subscriber

Hi there, A few more comments on the MQTT-Module. The module has a field for base topic and two postfixes for getting the value and setting the value. This does not work with e.g. the Shelly 2.5, which accepts a setting value with shellies/shellyswitch25-<deviceid>/relay/<i>/command and reports the ...
by ridewithstyle
25 Jun 2019 16:44
Forum: Discussions in English
Topic: MQTT Subscriber
Replies: 5
Views: 2341

Re: MQTT Subscriber

Hi there, Today I took the time and planned to dig a little into the MQTT Module and it turns out I can do everything I wanted without a single change of code. Documentation of the Module says that you can set the values of the device you published by sending "on" or "off" to them, something I tried...
by ridewithstyle
05 May 2019 19:00
Forum: Discussions in English
Topic: HTTP API for Scene access / error logging
Replies: 17
Views: 3837

Re: HTTP API for Scene access / error logging

Hi PoltoS, I added the fix and now the access works as expected. A Little side effect is though that if you navigate to ZWay:8083/smarthome you are presented with a user/Password window by your browser. Looks like the Webhandler doesn't differentiate between accesses for the administration page and ...
by ridewithstyle
19 Apr 2019 22:51
Forum: Discussions in English
Topic: MQTT Subscriber
Replies: 5
Views: 2341

Re: MQTT Subscriber

Thanks for the clarification. I might take a look into the module, but as I don't speak the language that might take a while before I reach the point of contribution worthy code.

Best Regards,
rws
by ridewithstyle
19 Apr 2019 22:48
Forum: Discussions in English
Topic: HTTP API for Scene access / error logging
Replies: 17
Views: 3837

Re: HTTP API for Scene access / error logging

Hi PoltoS,

thanks for the replay and the fix. Will try it as soon as I am back at home, left for vacation today.

Btw, I accidently posted the authentication free python script I set up for my first try. Will add the one with proper authentication once I return.

Best regards,
rws
by ridewithstyle
16 Apr 2019 23:06
Forum: Discussions in English
Topic: HTTP API for Scene access / error logging
Replies: 17
Views: 3837

Re: HTTP API for Scene access / error logging

Hi there, since I haven't heard from any developer I had the impression that I was on my own. Not nice but as developer myself I had to find a workaround, daily business. Forcing the entrycom to plain-text send a user:password wasn't possible and getting ZWay to reply in a RFC compliant way, proved ...
by ridewithstyle
15 Apr 2019 19:17
Forum: Discussions in English
Topic: MQTT Subscriber
Replies: 5
Views: 2341

MQTT Subscriber

Hi there, this weekend I experimented a little with MQTT, set up mosquitto as broker and sucessfully published ZWay device status event to the broker. Is it possible to subscribe from Zway to the MQTT broker and subscribe to topics? I would like to integrate MQTT Sensors into my ZWay rules and autom...
by ridewithstyle
19 Mar 2019 16:33
Forum: Discussions in English
Topic: HTTP API for Scene access / error logging
Replies: 17
Views: 3837

Re: HTTP API for Scene access / error logging

Would someone be willing to add the proper reply to ask for basic authentication? This is currently really a blocking point for me.

Best regards,
rws
by ridewithstyle
11 Mar 2019 13:00
Forum: Discussions in English
Topic: Send SensorMultilevel unsolicited from controller
Replies: 36
Views: 7672

Re: Send SensorMultilevel unsolicited from controller

Hi there,

somehow my attachments disappeared, did I violate any forum rules?

Regards,
rws