Search found 13 matches

by samsonbox
18 Jul 2019 08:36
Forum: Z-Uno
Topic: FLiRS with 2.1.5 release
Replies: 0
Views: 26

FLiRS with 2.1.5 release

Hallo, I would like to implement an FLiRS Device with new 2.1.5 release and the dynamic channel asignement. I havethe following code: #include <ZUNO_BMP280.h> #include "Wire.h" ZUNO_SETUP_SLEEPING_MODE(ZUNO_SLEEPING_MODE_FREQUENTLY_AWAKE); ZUNO_ENABLE(LOGGING_EVENTS LOGGING_UART=Serial WITH_CC_SENSO...
by samsonbox
17 Jul 2019 22:23
Forum: Z-Uno
Topic: New 2.1.5 release
Replies: 14
Views: 986

Re: New 2.1.5 release

Hi all, I have great problems with the new release and old software. Could you kindly send me an an example of a sensor multilevel device with 3 channels? I was using the following code in order to setup the 3 channels: ZUNO_SETUP_CHANNELS( ZUNO_SENSOR_MULTILEVEL( ZUNO_SENSOR_MULTILEVEL_TYPE_GENERA...
by samsonbox
16 Jul 2019 22:55
Forum: Z-Uno
Topic: New 2.1.5 release
Replies: 14
Views: 986

Re: New 2.1.5 release

I have a problem with the ZUNO_SETUP_SLEEPING_MODE(ZUNO_SLEEPING_MODE_FREQUENTLY_AWAKE); with the loop I call zunoSetBeamCountWU(10); zunoSendDeviceToSleep(); but the device does not wake up any more. The Battery and wake_up command class is also missing on the contoller side. But in react on any co...
by samsonbox
16 Jul 2019 22:42
Forum: Z-Uno
Topic: z-uno module stops working when USB is not connected
Replies: 3
Views: 538

Re: z-uno module stops working when USB is not connected

The same problem observed. When USB_DM is pulled up to +3.3V (after the programming!) by 10kOhm resistor the sketch works properly. That is what I did as well now. Do you have anSUB connector on your module? Or just headers? I have the suspicion that the chip does something strange. You can observe...
by samsonbox
11 Jul 2019 23:32
Forum: Z-Uno
Topic: New 2.1.5 release
Replies: 14
Views: 986

Re: New 2.1.5 release

Thank you for your answer.

Does
We have fixed this. Please reinstall the cores.
mean one should reinstall the core via the arduino ide?
by samsonbox
09 Jul 2019 23:47
Forum: Z-Uno
Topic: New 2.1.5 release
Replies: 14
Views: 986

Re: New 2.1.5 release

New channel mapping to channel 0 If the channel appears only once, it will not be inside MultiChannel, but rather on the root (channel 0) device only. Additional channels are not created anymore for that case. Is it possible to get the old behaviour backagain? I would like get the Status of the ind...
by samsonbox
02 Jul 2019 19:01
Forum: Z-Uno
Topic: z-uno module stops working when USB is not connected
Replies: 3
Views: 538

Re: z-uno module stops working when USB is not connected

Ok I have a few more information about my problem: 1) the z-uno module is really alive and just trappen in something. I implemented a counteron the serial port and it just stops counting when I plug of the USB cable and continous counting when the cable ispluged in again. 2) WhenI plug off the USB c...
by samsonbox
29 Jun 2019 01:24
Forum: Z-Uno
Topic: z-uno module stops working when USB is not connected
Replies: 3
Views: 538

z-uno module stops working when USB is not connected

Hello together, I have a problem with the z-uno module. I have connected the USB_DP, USB_DM and GND to a USB cable. The VCC andGND is connected to a 3.3V power supply (as depiced in the reference). Pin 13 is wired to a LED (including a fitting resistor). With this setup i can reach the module via US...
by samsonbox
08 Jun 2019 22:45
Forum: Z-Uno
Topic: Multilevel sensors and the 30 second rule
Replies: 4
Views: 480

Re: Multilevel sensors and the 30 second rule

Hallo together, I have another short question to this topic. This 30 second rule only applies within one channel right? So if I have a sketch with multiple ZUNO_SENSOR_MULTILEVEL channels, each channel can send a report every 30 seconds. But I can send a report for channel 2 right after channel one?...
by samsonbox
03 Oct 2016 22:37
Forum: Z-Uno
Topic: Using structs in a struct
Replies: 2
Views: 1075

Using structs in a struct

Hello together, when i try to use a stuct in a second struct like this: struct s1{ byte b1; }; struct s2 { s1 s; byte b2; }; i always get the following comiler error: C:\Users\xxx\AppData\Local\Temp\build6209164666085632177.tmp\_test_ucxx.c:272: syntax error: token -> 'static' ; column 11 Error. SDC...