Search found 4 matches

by rumen33
15 Jul 2019 20:25
Forum: Z-Uno
Topic: z-uno module stops working when USB is not connected
Replies: 3
Views: 909

Re: z-uno module stops working when USB is not connected

The same problem observed. When USB_DM is pulled up to +3.3V (after the programming!) by 10kOhm resistor the sketch works properly.
by rumen33
14 Oct 2016 18:43
Forum: Z-Uno
Topic: Z-Uno - negative temperature value from DS18B20
Replies: 12
Views: 6045

Re: Z-Uno - negative temperature value from DS18B20

Hi P0lyg0n1, This is just to confirm the problem is solved. Thank you! I didn't realize it immediately as there was another error to fix in the sketch. Now, after editing the library file according to your advice, temperature readings are restoring in 15-20 seconds, without Z-Uno reset. Thanks to ev...
by rumen33
09 Oct 2016 10:44
Forum: Z-Uno
Topic: Z-Uno - negative temperature value from DS18B20
Replies: 12
Views: 6045

Re: Z-Uno - negative temperature value from DS18B20

Hi p0lyg0n1. Thank you for your detailed explanation. However this is not case as in the original example, used by me, the device is not defined as a battery supplied. The problem exists even in case of: ZUNO_SETUP_SLEEPING_MODE(ZUNO_SLEEPING_MODE_ALWAYS_AWAKE); Does anybody else tried this example....
by rumen33
07 Oct 2016 14:50
Forum: Z-Uno
Topic: Z-Uno - negative temperature value from DS18B20
Replies: 12
Views: 6045

Z-Uno - negative temperature value from DS18B20

After switching Z-Uno power supply Off for about 10 sec and the switching it back ON, the temperature readings from 1-WIRE temperature sensor DS18B20 are going to -327 Deg. The problem exists even with the example sketch for 1-WIRE temperature sensor, posted on Z-Uno web site. I found this value is ...