Search found 49 matches

by schmidmi
05 Nov 2017 01:21
Forum: Z-Uno
Topic: Problem with 2.1.1
Replies: 3
Views: 221

Re: Problem with 2.1.1

After several retries of uploading the firmware and sketch, no it works fine. But I had to exclude and include the device in my HC 2.
Problem solved!
by schmidmi
05 Nov 2017 01:20
Forum: Z-Uno
Topic: Pin 5 in INPUT_PULLUP mode isn't pulled HIGH
Replies: 5
Views: 280

Re: Pin 5 in INPUT_PULLUP mode isn't pulled HIGH

This problem is not only at pin 5. I had the same problem at pin 18. But the workaround works :)
by schmidmi
05 Nov 2017 00:05
Forum: Z-Uno
Topic: Problem with 2.1.1
Replies: 3
Views: 221

Re: Problem with 2.1.1

I made some further investigations.
When not using my DS18B20 the sketch is not blocked anymore but still no connection to my HC2.
Do i have to exclude and include the device in my HC2?
by schmidmi
05 Nov 2017 00:02
Forum: Z-Uno
Topic: Problem with 2.1.1
Replies: 3
Views: 221

Problem with 2.1.1

I did a upgrade of the Adruino IDE to 1.8.5. Then I installed the Z-UNO 2.1.1 board and made an upgrade for the bootloader on the Z-UNO. All these steps worked fine. Then I made a download of my sketch wich was running fine with Arduino 1.6.5 and Z_UNO 2.0.9. After about 2 cycles Z-UNO stops working...
by schmidmi
16 Oct 2017 17:05
Forum: Z-Uno
Topic: Mobile Z-Uno and connection loss
Replies: 7
Views: 310

Re: Mobile Z-Uno and connection loss

I think, a robot which is moving around should be challenge for the network.
Because with respect to the conditions for the Z-wave signal, the device needs several different routes on its way through the house.
by schmidmi
12 Oct 2017 10:16
Forum: Z-Uno
Topic: Multiple buttons
Replies: 5
Views: 363

Re: Multiple buttons

There is only one thing I can see:
You have some unnecessary brackets in your code.
The bracket before Serial.println("0. "); and after zunoSendReport(..); seem to be useless.
by schmidmi
06 Oct 2017 15:00
Forum: Z-Uno
Topic: New 2.1.1 test build is ready!
Replies: 17
Views: 1256

Re: New 2.1.1 test build is ready!

I think you mean "Arduino IDE 1.6.5 and 1.8.5 are now supported", isn't it?
by schmidmi
05 Oct 2017 16:14
Forum: Z-Uno
Topic: Z-UNO blocked after several hours of operation
Replies: 27
Views: 1139

Re: Z-UNO blocked after several hours of operation

@MastrUsr:
I've sent a PM to you :)
by schmidmi
04 Oct 2017 11:50
Forum: Z-Uno
Topic: Z-UNO blocked after several hours of operation
Replies: 27
Views: 1139

Re: Z-UNO blocked after several hours of operation

Yes, I tried a lot of things with the GPT, but it was not working as expected. I'm rather sure, that there is or was a problem in the GPT firmware too. Another reason could be, that the write access to an output pin is too slow to react within a timescale of a few hundreds microseconds. But as you s...
by schmidmi
04 Oct 2017 10:22
Forum: Z-Uno
Topic: float conversion
Replies: 18
Views: 740

Re: float conversion

Maybe we have here the same problem, I saw while write an float to the OLED display with oled.print(...)?