Search found 10 matches

by risca
13 Mar 2018 18:41
Forum: Z-Uno
Topic: Z-uno is running much slower on PC power than on charger
Replies: 19
Views: 3388

Re: Z-uno is running much slower on PC power than on charger

I got the opposite result than me. I got: * Laptop - slow * Power supply - fast The results you posted seem to indicate the opposite. Would it be possible to detect the current running speed and make code that works for both speeds? Or maybe contact the MCU manufacturer about this issue? They might ...
by risca
02 Mar 2018 19:04
Forum: Z-Uno
Topic: Z-uno is running much slower on PC power than on charger
Replies: 19
Views: 3388

Re: Z-uno is running much slower on PC power than on charger

I'll see what I can do. We have guests visiting for the weekend so it might have to wait until next week. Additionally, I've already switched to a different design that uses the builtin UART and a separate MCU to add parity. I don't need the software UART anymore. However, it would be most interesti...
by risca
02 Mar 2018 17:53
Forum: Z-Uno
Topic: Z-uno is running much slower on PC power than on charger
Replies: 19
Views: 3388

Re: Z-uno is running much slower on PC power than on charger

I'm not using the builtin UART, I'm doing software (bitbang) UART. I disable all interrupts before sending a byte and enable it again after 1 byte is sent. Basically, before and after the time critical section of my code. See the code in my initial post. The only pins I have connected are 5 V, GND, ...
by risca
28 Feb 2018 04:48
Forum: Z-Uno
Topic: Z-uno is running much slower on PC power than on charger
Replies: 19
Views: 3388

Re: Z-uno is running much slower on PC power than on charger

I don't have any 3 V power supplies, or do you mean to connect 5 V to the 3 V pin?
by risca
23 Feb 2018 22:33
Forum: Z-Uno
Topic: Z-uno is running much slower on PC power than on charger
Replies: 19
Views: 3388

Re: Z-uno is running much slower on PC power than on charger

Yes, it seems that way. The Z-uno seem to work fine in both cases, just 2 different speeds.
by risca
23 Feb 2018 02:13
Forum: Z-Uno
Topic: Even parity for UART
Replies: 2
Views: 785

Re: Even parity for UART

Ok. I've ordered a SPI-UART bridge that should solve this. I'll see when it arrives.
by risca
23 Feb 2018 02:10
Forum: Z-Uno
Topic: Z-uno is running much slower on PC power than on charger
Replies: 19
Views: 3388

Re: Z-uno is running much slower on PC power than on charger

I've done some more experiments on this now. Things I have powered the z-uno with that makes it run slow: my laptop (USB cable, 5 V, ? A) old Siemens phone charger (5 V, 700 mA) soldered to +5 V and GND. Things I have powered the z-uno with that makes it run fast: USB charger (5 V, 2.5 A) powered US...
by risca
17 Feb 2018 00:43
Forum: Z-Uno
Topic: Z-uno is running much slower on PC power than on charger
Replies: 19
Views: 3388

Z-uno is running much slower on PC power than on charger

Hello, I'm creating a sketch to control my projector at home. Unfortunately, my projector requires a (9:th) parity bit for UART communication ( see other topic ), so I decided to bitbang the protocol. Here's the code: // LED pin number #define LED_PIN 13 #define START_CODE ((char)0xA9) #define END_C...
by risca
11 Feb 2018 05:59
Forum: Z-Uno
Topic: Even parity for UART
Replies: 2
Views: 785

Even parity for UART

Hello,

I have an application that requires 8E1, i.e. even parity, to communicate. Is it possible to configure Serial0 or Serial1 for even parity?

Best regards
// Patrik