Search found 5 matches

by Atomic
17 Oct 2019 20:31
Forum: RaZberry
Topic: Device dead after bootloader / fw upgrade
Replies: 3
Views: 481

Re: Device dead after bootloader / fw upgrade

Now I went all the way up to 5.37, the leds are on for 2 seconds on restart, but z-way-server still sais device dead. ./ZMESerialUpdater serialapi_uzbupdate -d /dev/ttyAMA0 -f UPD_FIRMWARE_Razberry_STATIC_2ch_ZME_05_20_04000002_ZME_05_24_04000002.bin Z-WAVE Serial API Tool Version:LWE0.9 by Z-WAVE>M...
by Atomic
17 Oct 2019 19:57
Forum: RaZberry
Topic: Device dead after bootloader / fw upgrade
Replies: 3
Views: 481

Re: Device dead after bootloader / fw upgrade

I powercycled my pi, and it seems the data is back: ./ZMESerialUpdater serialapi_uzbupdate -d /dev/ttyAMA0 Z-WAVE Serial API Tool Version:LWE0.9 by Z-WAVE>ME --> Device ready in:3.05762982368 seconds FULL INFO Openning port .............................. OK SERIAL INFO VERSION: 05 17 VENDOR: 01 47 Z...
by Atomic
17 Oct 2019 19:40
Forum: RaZberry
Topic: Device dead after bootloader / fw upgrade
Replies: 3
Views: 481

Device dead after bootloader / fw upgrade

I upgraded from 5.04 -> 5.07 -> 5.17 and now the device is marked dead in z-way 3.0.0 When upgrading to 5.07, I also upgraded the bootloader, which worked ok: ARGS:['./ZMESerialUpdater', 'serialapi_uzbupdate', '-d', '/dev/ttyAMA0', '-b', 'bootloader_Razberry_from_05_04_to_8aaa_2MB.bin', '-f', 'UPD_F...
by Atomic
05 Sep 2019 11:50
Forum: Discussions in English
Topic: 3.0.0: CGI program sent malformed or to big
Replies: 1
Views: 360

3.0.0: CGI program sent malformed or to big

I've got a new Raspberry with Z-Way Server 3.0.0 and cannot access the fw updater. All I get is this error message: Error 500: Internal Server Error CGI program sent malformed or too big (>16384 bytes) HTTP headers: [] In the z-way-server log file I see no output when the error occurs. I already sta...
by Atomic
28 Jun 2019 20:36
Forum: RaZberry
Topic: Support for Buster?
Replies: 4
Views: 1322

Support for Buster?

Currently, Z-Way FW updates do not work on Buster, as mongoose is compiled against a very old version of libssl. Even "tricking" by modifying /etc/init.d/mongoose to use the provided old libssl library only works partially ("header to large") LD_LIBRARY_PATH="/opt/z-way-server/libs/:${LD_LIBRARY_PAT...