First Alert - Smoke and CO Detector

Discussions about Z-Way software and Z-Wave technology in general
nybble
Posts: 26
Joined: 04 Jun 2015 19:37

First Alert - Smoke and CO Detector

Post by nybble » 18 Jul 2015 01:45

Hello all!

I'm wondering if anyone has had experiences with pairing a First Alert Smoke and CO Detector to their network.

I picked one up today, and can successfully pair the device to my network, but unfortunately, the device goes to sleep after 30 seconds, and the interview process doesn't complete.

As an FYI I'm running the v2.0.2 RC that was released on July 16th.

Any help would be appreciated!

toomuo
Posts: 23
Joined: 01 Jan 2015 20:14

Re: First Alert - Smoke and CO Detector

Post by toomuo » 18 Jul 2015 17:53

Same problem here, left it like that for several months now, interview incomplete.
Advice on discussion boards for other controllers was generally to keep trying to exclude / re-include, but it didn't help here. There's an older thread in the device specific area.

christian.paetz
Posts: 10
Joined: 25 May 2014 15:39

Re: First Alert - Smoke and CO Detector

Post by christian.paetz » 18 Jul 2015 21:48

Hi, can you share what part of interview is not complete, log file is even better. Indeed this device was never tested with razberry so makes sense to dig into it. I guess we talk about http://products.z-wavealliance.org/products/863

nybble
Posts: 26
Joined: 04 Jun 2015 19:37

Re: First Alert - Smoke and CO Detector

Post by nybble » 20 Jul 2015 19:06

I'll gladly get you a log! Just let me know where to look and I'll remove and readd the device to my network.

pz1
Posts: 2053
Joined: 08 Apr 2012 13:44

Re: First Alert - Smoke and CO Detector

Post by pz1 » 20 Jul 2015 19:53

nybble wrote:I'll gladly get you a log! Just let me know where to look and I'll remove and readd the device to my network.
On the RaspberryPi
/var/log/z-way-server.log

nybble
Posts: 26
Joined: 04 Jun 2015 19:37

Re: First Alert - Smoke and CO Detector

Post by nybble » 21 Jul 2015 02:55

According to the Configuration tab for the device under the Expert UI - The interview fails at the Basic Commands section of the interview process.

I was unable to attach a .txt or .log output to this post, so I have included a link to the contents of the z-way-server.log file in a pastebin link here -> http://pastebin.com/m0J4c1RX
Attachments
Screen Shot 2015-07-20 at 7.51.11 PM.png
Interview Results
Screen Shot 2015-07-20 at 7.51.11 PM.png (56.06 KiB) Viewed 5844 times
Screen Shot 2015-07-20 at 7.50.58 PM.png
Configuration Tab
Screen Shot 2015-07-20 at 7.50.58 PM.png (82.11 KiB) Viewed 5844 times
Last edited by nybble on 21 Jul 2015 02:57, edited 1 time in total.

nybble
Posts: 26
Joined: 04 Jun 2015 19:37

Re: First Alert - Smoke and CO Detector

Post by nybble » 21 Jul 2015 02:57

Additionally - If I try to force an interview of the device, the device immediately reports that it is in deep sleep and doesn't wake up.

Repeating the "Inclusion" process on the alarm will wake it up, but it fails at the same step of the interview as originally posted above.
Attachments
Screen Shot 2015-07-20 at 7.56.36 PM.png
Forced Interview.
Screen Shot 2015-07-20 at 7.56.36 PM.png (78.57 KiB) Viewed 5844 times

nybble
Posts: 26
Joined: 04 Jun 2015 19:37

Re: First Alert - Smoke and CO Detector

Post by nybble » 21 Jul 2015 03:18

christian.paetz wrote:Hi, can you share what part of interview is not complete, log file is even better. Indeed this device was never tested with razberry so makes sense to dig into it. I guess we talk about http://products.z-wavealliance.org/products/863
Just so we're all on the same page - We're talking about this device. http://products.z-wavealliance.org/products/862

Same manufacturer, but a slightly different model.

nybble
Posts: 26
Joined: 04 Jun 2015 19:37

Re: First Alert - Smoke and CO Detector

Post by nybble » 04 Aug 2015 22:23

Hey all! Just giving this a little bump to see if anyone has had a chance to review any of the information I posted!

Thanks again for all your help!

jhmartin
Posts: 29
Joined: 14 Apr 2015 02:52

Re: First Alert - Smoke and CO Detector

Post by jhmartin » 15 Aug 2015 06:06

Same here, fails on the 'basic' portion of the interview and all portions can complete.

Log output is:
[2015-08-14 20:06:05.460] [zway] Job 0x13 (Basic Get): Delivered
[2015-08-14 20:06:05.460] [D] [zway] SETDATA devices.61.data.lastPacketInfo.delivered = True
[2015-08-14 20:06:05.460] [D] [zway] SETDATA devices.61.data.lastPacketInfo.packetLength = 5 (0x00000005)
[2015-08-14 20:06:05.461] [D] [zway] SETDATA devices.61.data.lastPacketInfo.deliveryTime = 24 (0x00000018)
[2015-08-14 20:06:05.461] [D] [zway] SETDATA devices.61.data.lastPacketInfo = **********
[2015-08-14 20:06:05.461] [D] [zway] SendData Response with callback 0x4a received: received by recipient
[2015-08-14 20:06:05.461] [D] [zway] SETDATA devices.61.data.lastSend = 150408 (0x00024b88)
[2015-08-14 20:06:05.462] [D] [zway] Job 0x13 (Basic Get): success
[2015-08-14 20:06:05.462] [zway] Removing job: Basic Get

This is with 2.0.1. Manual is at http://www.lowes.com/pdf/First%20Alert% ... tector.pdf.
Last edited by jhmartin on 22 May 2016 05:43, edited 1 time in total.

Post Reply