Community Module: HomeKit

Discussions about Z-Way software and Z-Wave technology in general
Post Reply
vga
Posts: 59
Joined: 18 Dec 2014 11:28

Community Module: HomeKit

Post by vga » 07 Feb 2016 16:22

Hi everyone,

are there any news about the community Module for HomeKit?
Would be nice to get some information about development state and when to expect it.

best regards,
vga

leonmf
Posts: 44
Joined: 23 Oct 2014 02:59

Re: Community Module: HomeKit

Post by leonmf » 08 Feb 2016 07:04

Homebridge is not that hard to setup but I found it better to setup on a second raspberry pi rather than sharing with my Z-Way install. It worked on my rpi2 with both installed but the whole thing crashed after a few days. It's been runniing fine for a couple of weeks with Z-Way on the rpi2 and Homebridge on a rpiB+.

As an added bonus, there are modules for Nest and other devices as well as Z-Way which all integrate with Homebridge.

https://github.com/SphtKr/homebridge-zway

There's a little more setup involved to get this working than the function that used to be built into Z-way but Homekit seems to work much better with Homebridge.

vga
Posts: 59
Joined: 18 Dec 2014 11:28

Re: Community Module: HomeKit

Post by vga » 09 Feb 2016 18:56

yes, thanks for your answer.
i´ve set up a second rpi2 for homebridge with homebridge-zway plugin. ´
All works fine, even siri is working again! :)
I can also only recommend!

Mansica
Posts: 16
Joined: 17 Feb 2016 23:51

Re: Community Module: HomeKit

Post by Mansica » 18 Feb 2016 00:06

May I ask what versions you are using. I followed this guide: https://github.com/nfarina/homebridge/w ... spberry-Pi and installed z-way server 2.2.1, homebridge 0.2.8 and homebridge-zway 0.4.0. I get a parse error in my error log when I try to start the homebridge server. I cant however access the login api correctly. I just get this message: Uncaught TypeError: 'Cannot read property 'call' of undefined'

senad
Posts: 2
Joined: 22 Mar 2016 19:38

Re: Community Module: HomeKit

Post by senad » 26 Mar 2016 22:44

vga wrote:yes, thanks for your answer.
i´ve set up a second rpi2 for homebridge with homebridge-zway plugin. ´
All works fine, even siri is working again! :)
I can also only recommend!
HI, can you please explain how you connected your homebridge to z-wave I am working on this last 2 days.


Thanks.

silverhack
Posts: 46
Joined: 23 May 2016 21:41

Re: Community Module: HomeKit

Post by silverhack » 24 May 2016 01:49

senad wrote: HI, can you please explain how you connected your homebridge to z-wave I am working on this last 2 days.
Did you get yours working? I just got mine working two days ago.
I also followed this guide:
https://github.com/nfarina/homebridge/w ... spberry-Pi

Post Reply