Devices lost after upgrade / downgrade

Discussions about Z-Way software and Z-Wave technology in general
nic_rt
Posts: 29
Joined: 26 Sep 2015 15:00

Re: Devices lost after upgrade / downgrade

Post by nic_rt » 22 Jul 2016 14:49

Dear all,
it seems that since v2.2.2 some older razberry are no more compatible, and won't be compatible again. When I try to go back to the version I had before (v2.1.1), I've the same issues : starting from nothing, I reinclude all the devices, all are working fine but after on/off of Raspberry, all devices disappear. It looks like it is no more possible to use my hardware whatever the vesion of the sofware ...
On one hand, I'm happy to see that I'm not the only one facing this situation, but on the other hand I'm disappointed to see the lost of time, spent trying to recover towards something that was working fine before.
I can't see any solution, hope someone will find...
Nick


Raspberry + Razberry + FGS221 x 4 + FGRM 222 + Aeon Labs Micro Motor Controller + FGK 101 + Z-Wave Aeotec Smart Plug-in Switch GEN5 + Minimote + Aeotec KeyFob + Greenwave Smart Power Node x 2

thaui
Posts: 56
Joined: 28 Jan 2015 19:14

Re: Devices lost after upgrade / downgrade

Post by thaui » 15 Aug 2016 11:17

Dear all, I only can say that the support from Z-wave.me and also Zwave Europe is at a very concerning low Level or they what to keep something secret. Why not documenting a Software in a proper manner? Users are doing the fieldtesting from version to version. After losing all my devices after installing one of the last releases I was searching for a backup solution for the Controller data. I gambled arround with the AEON Gen5 stick and I found out backup and restore works perfect. They have a small Software reading and writing the EEPROM data. A phone call at Zwave Europe as the sole Distributor of the Razberry board brought no news. Cloning a Razberry is not possible they told me because of the home ID. Suddenly I found this article and I tried it out. It works perfect. Now I have a backup of my controller which is a copy of the master unit. Just in case that the master unit will be corrupted. On the other hand I can rely on the backup I did with Version 2.2.-RC4. Here ist the link to the article. Thanks to this genious IP Symcon user https://www.symcon.de/forum/attachment. ... 1459447602 Hope this will help many others who have similar problems. A backup of the controller is essential and you have to rely on this. Dear developer pls. think about this. Trail and error is a no go if you run the Razberry in a productive environment.

User avatar
PoltoS
Posts: 4536
Joined: 26 Jan 2011 19:36

Re: Devices lost after upgrade / downgrade

Post by PoltoS » 17 Aug 2016 04:33

Had you a look on this document ?
https://raw.githubusercontent.com/Z-Wav ... wayUse.pdf
Section 5.6 Backup and Restore

We will make a revision of the paper to make it more up to date and make new screenshots to make it more comprehensive.

As for Aeotec tool to copy EEPROM, it can work for RaZberry too, but this is a clear violation of license agreement and Sigma Designs rules, so being European company we don't do it. Hopefully Sigma Designs wants to make this public in future and we will be able to open this to public too.

Current RaZberry/Z-Way implementation uses better approach and also allows to port from 3rd gen to 5th gen and back, which is not possible with Aeotec tool.

User avatar
PoltoS
Posts: 4536
Joined: 26 Jan 2011 19:36

Re: Devices lost after upgrade / downgrade

Post by PoltoS » 17 Aug 2016 15:00

BTW, we have even a more recent doc on our official web site: https://razberry.z-wave.me/docs/RaZberr ... nual20.pdf It also describes the backup/restore.

Post Reply