Page 4 of 4

Re: z-way-server does not start in Stretch

Posted: 20 Mar 2018 15:43
by coolbloke1324
Hey folks,

Not ideal, but you can install libssl1.0.0 on stretch by running:

Code: Select all

wget http://ftp.de.debian.org/debian/pool/main/o/openssl/libssl1.0.0_1.0.1t-1+deb8u7_amd64.deb
sudo apt install ./libssl1.0.0_1.0.1t-1+deb8u7_amd64.deb
After this, I was able to run z-way-server on stretch.

Re: z-way-server does not start in Stretch

Posted: 28 Apr 2018 15:09
by Mir88d
coolbloke1324 wrote:
20 Mar 2018 15:43
Hey folks,

Not ideal, but you can install libssl1.0.0 on stretch by running:

Code: Select all

wget http://ftp.de.debian.org/debian/pool/main/o/openssl/libssl1.0.0_1.0.1t-1+deb8u7_amd64.deb
sudo apt install ./libssl1.0.0_1.0.1t-1+deb8u7_amd64.deb
After this, I was able to run z-way-server on stretch.
It doesn't help me at all :

Code: Select all

sudo apt install ./libssl1.0.0_1.0.1t-1+deb8u7_amd64.deb
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'libssl1.0.0:amd64' instead of './libssl1.0.0_1.0.1t-1+deb8u7_amd64.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libssl1.0.0:amd64 : Depends: libc6:amd64 (>= 2.14) but it is not installable
E: Unable to correct problems, you have held broken packages.
And I can't instal Raspbian Jassie because I have Raspberry Pi 3 B+ which is incompatible with old Jessie.
I think the only way for me is returning UZB stick...

Maybe someone knows another z-wave server which is compatible with z-wave.me UZB stick and Raspbian Stretch?

Re: z-way-server does not start in Stretch

Posted: 28 Apr 2018 23:09
by aLiEnHeAd
Mir88d wrote:
28 Apr 2018 15:09
Maybe someone knows another z-wave server which is compatible with z-wave.me UZB stick and Raspbian Stretch?
This solution did not work for you?
https://forum.z-wave.me/viewtopic.php?f=3417&t=26138

Re: z-way-server does not start in Stretch

Posted: 11 May 2018 12:47
by Mir88d
aLiEnHeAd wrote:
28 Apr 2018 23:09
Mir88d wrote:
28 Apr 2018 15:09
Maybe someone knows another z-wave server which is compatible with z-wave.me UZB stick and Raspbian Stretch?
This solution did not work for you?
https://forum.z-wave.me/viewtopic.php?f=3417&t=26138
Thank you! It’s solved my problem

Re: z-way-server does not start in Stretch

Posted: 23 Aug 2018 02:40
by epoitras
It's been a year now this issue is open. It should really be time to fix it and support stretch.

Re: z-way-server does not start in Stretch

Posted: 27 Aug 2018 20:29
by PoltoS
Please try this:

Code: Select all

VER="2.3.8-rc6" && cd /tmp/ && rm -f *.deb && wget https://storage.z-wave.me/z-way-server/z-way-${VER}_armhf.deb && wget https://storage.z-wave.me/z-way-server/webif-1.1_armhf.deb && wget https://storage.z-wave.me/z-way-server/zbw-1.1_all.deb && sudo dpkg -i *.deb
Answer:

Code: Select all

Y on /etc/init.d/z-way-server
Y on /etc/logrotate.d/z-way-server
N on /etc/zbw/userid
N on /etc/zbw/passwd
N on /etc/zbw/local_port

Re: z-way-server does not start in Stretch

Posted: 02 Sep 2018 08:49
by skavan
port 1883 doesn't activate.
presumably because of some failure pre-launch.
I have tried your suggestions above (VER= bla bla bla).
This is quite ridiculous. Stretch has been the default OS for the rpi for ages. I bought the razberry to use with zway...and it is nuts that I have zero functionality.
Please give me a step by step on how to get this working on a Pi 3 with Stretch. The Razberry is attached to dev/ttyS0.

Re: z-way-server does not start in Stretch

Posted: 06 Sep 2018 22:13
by stkar
Hi

Eureka!

Downloaded
2018-06-27
Stretch 4.14

Downloaded
RaZBerry 2.3.7

Thanks for this "mtylerb" you are a God!!!
https://www.raspberrypi.org/forums/view ... p?t=215389

Now with changed to "9".

$ cd \tmp
$ wget http://mirrordirector.raspbian.org/rasp ... _armhf.deb
$ sudo dpkg -x libssl1.0.0_1.0.1t-1+deb8u9_armhf.deb .
$ sudo mv usr/lib/arm-linux-gnueabihf/lib* /opt/z-way-server/libs/

Maybe last sudo mv with some permission change ... do not remember exactly.

Wow, everything works (22 aug)!