Cannot start Z-Wave binding: Error: Bad data - communication failed

Discussions about Z-Way software and Z-Wave technology in general
Post Reply
caiusjulius.caesar
Posts: 1
Joined: 11 Feb 2018 17:24

Cannot start Z-Wave binding: Error: Bad data - communication failed

Post by caiusjulius.caesar » 11 Feb 2018 17:44

I installed in a Raspberry Pi 3
  • *Jessie (the full, not the preconfigured version)
    * the razberry Z-Wave bridge
    * the Z-Wave.me Server.
I experience the following error:

Code: Select all

Cannot start Z-Wave binding: Error: Bad data - communication failed
What is wrong? What can I do? Is there any hint on the type of error, if you look into the logfile?

What does the error-message stand for?

Regards
CJC

Code: Select all

[2018-02-11 13:32:31.266] [D] [zway] SENDING: ( 01 03 00 07 FB )
[2018-02-11 13:32:31.266] [C] [i/o] Serial port write error: (null)
[2018-02-11 13:32:31.266] [E] [zway] Failed to send packet: (null)
[2018-02-11 13:32:31.266] [D] [zway] Worker thread exit point
[2018-02-11 13:32:31.266] [D] [zway] Worker thread successfully finished
[2018-02-11 13:32:31.276] [E] [zway] SaveData will not save data since it wasn't loaded. This is to prevent data loss.
[2018-02-11 13:32:31.277] [C] [zway] Get Serial API Capabilities returned zero.
[2018-02-11 13:32:31.295] [I] [core] Error: Bad data - communication failed
[2018-02-11 13:32:31.296] [I] [core] Tried 5 times without success. Stopping tries.
[2018-02-11 13:32:31.298] [I] [core] Notification: critical (z-wave): Cannot start Z-Wave binding: Error: Bad data - communication failed

User avatar
ronie
Posts: 55
Joined: 29 Jun 2015 09:50

Re: Cannot start Z-Wave binding: Error: Bad data - communication failed

Post by ronie » 12 Feb 2018 10:45

Hi CJC,

I suppose you're bluetooth isn't disabled ...
Usually that shouldn't be the case if you had install z-way by using this command:

Code: Select all

wget -q -O - razberry.z-wave.me/install | sudo bash
But maybe there went something wrong so you need to disable it again.
You can paste these lines:

Code: Select all

#!/bin/bash
# Prepare AMA0
sed 's/console=ttyAMA0,115200//; s/kgdboc=ttyAMA0,115200//; s/console=serial0,115200//' /boot/cmdline.txt > /tmp/zway_install_cmdline.txt

if [[ -e /etc/inittab ]]
then
	sed 's|[^:]*:[^:]*:respawn:/sbin/getty[^:]*ttyAMA0[^:]*||' /etc/inittab > /tmp/zway_install_inittab
fi

# Disable bluetooth Raspberry Pi 3
RPI_BOARD_REVISION=`grep Revision /proc/cpuinfo | cut -d: -f2 | tr -d " "`
if [[ $RPI_BOARD_REVISION ==  "a02082" || $RPI_BOARD_REVISION == "a22082" ]]
then
	echo "Raspberry Pi 3 Detected. Disabling Bluetooth"
	systemctl disable hciuart
	# Add "dtoverlay=pi3-miniuart-bt" to /boot/config.txt if needed
	if [[ ! `grep "dtoverlay=pi3-miniuart-bt" /boot/config.txt` ]]
	then
		echo "Adding 'dtoverlay=pi3-miniuart-bt' to /boot/config.txt"
		echo "dtoverlay=pi3-miniuart-bt" >> /boot/config.txt
	fi

	echo "!!! Update Raspberry Pi 3 Firmware for stability work with commands:"
	echo "sudo apt-get install rpi-update"
	echo "sudo rpi-update"
fi

if diff /boot/cmdline.txt /tmp/zway_install_cmdline.txt > /dev/null || diff /etc/inittab /tmp/zway_install_inittab > /dev/null
then
	rm /tmp/zway_install_cmdline.txt /tmp/zway_install_inittab
	# Starting z-way-server mongoose
else
	echo "Preparing AMA0 interface:"
	echo " removing 'console=ttyAMA0,115200' and 'kgdboc=ttyAMA0,115200 and 'console=serial0,115200' from kernel command line (/boot/cmdline.txt)"
	mv /tmp/zway_install_cmdline.txt /boot/cmdline.txt
	echo " removing '*:*:respawn:/sbin/getty ttyAMA0' from /etc/inittab"
	mv /tmp/zway_install_inittab /etc/inittab
	echo "AMA0 interface reconfigured, please restart Raspberry"
fi 
in a file on your RPi e.g. in your home directory (/home/pi):

Code: Select all

sudo nano disableBluetooth
make it executable and run it with:

Code: Select all

sudo chmod +x disableBluetooth
sudo ./disableBluetooth
If you're getting error massages abaout inititab you can ignore them.

These commands will install the RPi Update Manager for Raspberry Pi 3 and update it's firmware for stability work:

Code: Select all

sudo apt-get install rpi-update

Finally reboot your RPi:
[code]sudo reboot
If this won't help you can also check the Known Issues site from Z-Wave.Me

BR
ronie

AdrianAldea
Posts: 3
Joined: 15 Mar 2018 16:19

Re: Cannot start Z-Wave binding: Error: Bad data - communication failed

Post by AdrianAldea » 15 Mar 2018 17:09

Hello caiusjulius.caesar,

I had the same problem and I couldn't find any fix for it.

After I installed a preconfigured version everything was ok for me.

You can download a working image from z-wave site with z-wave server installed already :

Code: Select all

http://razberry.z-wave.me/z-way-server/razberry.img.zip

Post Reply