UZB Firmware Update from 5.07 to 5.27 fails

Discussions about Z-Way software and Z-Wave technology in general
rafale77
Posts: 31
Joined: 23 Jun 2018 19:26

Re: UZB Firmware Update from 5.07 to 5.27 fails

Post by rafale77 » 15 Dec 2018 09:33

It is a head scratcher...

the controller information shows:
ZWaveChip: ZW0500 (13.12.2018)
APIVersion: 05.23 (13.12.2018)
APIVersionMajor: 5 (13.12.2018)
APIVersionMinor: 23 (13.12.2018)
manufacturerId: 277 (13.12.2018)
vendor: Z-Wave.Me (13.12.2018)
manufacturerProductType: 1024 (13.12.2018)
manufacturerProductId: 1 (13.12.2018)
bootloaderCRC: 29304 (13.12.2018)
firmwareCRC: 52559 (13.12.2018)


But the url link shows

{"data":[{"id":"139","baseid":"","enabled":"enabled","type":"bootloader","file":"bin","vendorID":"277","bootloaderCRC":null,"appVersionMajor":"5","appVersionMinor":"23","targetBootloaderCRC":"40196","targetAppVersionMajor":null,"targetAppVersionMinor":null,"fileURL":"UPD_bootloader_UZB500_from__05_17_to_9D04.bin","released":"2017-07-05","comment":"Update bootloader for 5.23 to 40196","position":"1","version":"5.23"}]}

hunnypuppy
Posts: 6
Joined: 30 Jul 2019 19:25

Re: UZB Firmware Update from 5.07 to 5.27 fails

Post by hunnypuppy » 30 Jul 2019 20:51

Did anyone find the solution to this? I'm trying to update from 5.25 to the the latest version (using the v3.0.0 software on Ubuntu) - according to the firmware update screen it says update bootloader from 5.25 to 40196 but then when I click on Upgrade Bootloader it gives me an error

Code: Select all

Unable to update data. /ZWave.zway/ZMEBootloaderUpgrade

hunnypuppy
Posts: 6
Joined: 30 Jul 2019 19:25

Re: UZB Firmware Update from 5.07 to 5.27 fails

Post by hunnypuppy » 30 Jul 2019 23:23

I finally figured it out, use Ubuntu 16.04 and not 18.10 since z-way-server requires CURL3 (18.10 ships with CURL4). There was also a step to do a

Code: Select all

sudo chmod 666 /dev/ttyACM0
to allow z-way-server access to the device after EACH firmware update.

Post Reply