Page 1 of 5

UZB Firmware Update from 5.07 to 5.27 fails

Posted: 29 Apr 2018 17:38
by schreibubi
Hi all,

I've been trying to upgrade my UZB Stick to the latest firmware using the Z-Wave Expert UI (tried version 2.3.6 and 3.0.0rc). The first few updates up to 5.07 were no problem, but now the firmware upgrade page wants to install 5.27 (it offers 3 different versions of 5.27, I tried the EU version of the non-bridged and bridged variant). Firmware update runs without errors (I also checked the log-file and I see many messages saying it was able to successfully write to the eprom), but I'm still running version 5.07. Even unplugging/replugging the USB stick does not change this behaviour. Any idea what could be the issue?

Thanks a lot,

Joerg

Re: UZB Firmware Update from 5.07 to 5.27 fails

Posted: 19 May 2018 22:03
by stefxx
Hi, I am having the same issues. I am using 2.37, and after an attempt to upgrade my UZB1 (EU version) from 5.7 to 5.27, all seems fine and the log shows no errors, but the firmware remains 5.7 even after a reboot.

Did you ever find a solution?

Re: UZB Firmware Update from 5.07 to 5.27 fails

Posted: 22 May 2018 02:18
by iblis
Exactly the same behaviour here using zway-server 2.3.7 + UZB1 5.07. Please fix this z-wave.me!

Re: UZB Firmware Update from 5.07 to 5.27 fails

Posted: 03 Jun 2018 01:00
by Jeppo
Same here :(
Latest release on both Win 10 and Raspberry Pi

Re: UZB Firmware Update from 5.07 to 5.27 fails

Posted: 04 Jun 2018 00:17
by Jeppo
After several tries to update, my controllers Command Class now says
Basic • ApplicationStatus • SwitchBinary • SwitchMultilevel • SceneActivation • ClimateControlSchedule • TransportService • AssociationGroupInformation • DeviceResetLocally • CentralScene • ZWavePlusInfo • MultiChannel • Supervision • ManufacturerSpecific • PowerLevel • InclusionController • NodeNaming • Clock • Association • Version • Time • MultiChannelAssociation • SecurityS2 • Basic • SwitchBinary • SwitchMultilevel • SceneActivation • CentralScene • Basic • SwitchBinary • SwitchMultilevel • SceneActivation • CentralScene • Basic • SwitchBinary • SwitchMultilevel • SceneActivation • CentralScene • Basic • SwitchBinary • SwitchMultilevel • SceneActivation • CentralScene • Basic • SwitchBinary • SwitchMultilevel • SceneActivation • CentralScene • Basic • SwitchBinary • SwitchMultilevel • SceneActivation • CentralScene • Basic • SwitchBinary • SwitchMultilevel • SceneActivation • CentralScene • Basic • SwitchBinary • SwitchMultilevel • SceneActivation • CentralScene • Basic • SwitchBinary • SwitchMultilevel • SceneActivation • CentralScene • Basic • SwitchBinary • SwitchMultilevel • SceneActivation • CentralScene • Basic • SwitchBinary • SwitchMultilevel • SceneActivation • CentralScene • Basic • SwitchBinary • SwitchMultilevel • SceneActivation • CentralScene • Basic • SwitchBinary • SwitchMultilevel • SceneActivation • CentralScene • Basic • SwitchBinary • SwitchMultilevel • SceneActivation • CentralScene • Basic • SwitchBinary • SwitchMultilevel • SceneActivation • CentralScene • Basic • SwitchBinary • SwitchMultilevel • SceneActivation • CentralScene •
Is this normal?

Re: UZB Firmware Update from 5.07 to 5.27 fails

Posted: 15 Jun 2018 17:32
by missjocular
Is there any solution to solve the problem of the topic?

Re: UZB Firmware Update from 5.07 to 5.27 fails

Posted: 19 Jun 2018 08:34
by stefxx
I am still facing this issue as well... it seems we are being ignored...

Re: UZB Firmware Update from 5.07 to 5.27 fails

Posted: 04 Jul 2018 10:21
by stefxx
I tried another UZB with 5.23 installed. Upgrade to 5.27 worked flawlessly.

But my original stick with 5.07 still refuses to be upgraded. The upgrade process seems to work fine but after a reboot the firmware is still at 5.07.

As there are multiple reports of this issue, it cannot be that hard to reproduce I guess. A fix or workaround would be great. Is it perhaps possible to upgrade to another firmware version first, before upgrading to 5.27? I am only being offered 5.27 unfortunately.

Re: UZB Firmware Update from 5.07 to 5.27 fails

Posted: 05 Jul 2018 22:25
by rafale77
I am having the same problem. I have a brand new UZB I just got to day. upgraded firmware and bootloaders from 5.05 to 5.07. After 5.07 got another bootloader which upgraded fine and now it will crash every time I try to upgrade to 5.27.

One more thing too: The region frequency somehow changed from US to EU in between upgrades and I don't have the option to revert back. It is only giving choices of EU, RU, IN and CN. How do I revert back to US?

Re: UZB Firmware Update from 5.07 to 5.27 fails

Posted: 08 Jul 2018 18:08
by rafale77
I am now running 3.0.0 RC 15 and I get this error whenever I try to run the 5.07 to 5.27 upgrade on the UZB:
"Unable to update data. /ZWave.zway/ZMEFirmwareUpgrade"