Zway not starting on ubuntu

Discussions about Z-Way software and Z-Wave technology in general
Post Reply
rafale77
Posts: 19
Joined: 23 Jun 2018 19:26

Zway not starting on ubuntu

Post by rafale77 » 23 Jun 2018 19:31

Trying to install z-way with a UZB on an arm64 ubuntu with kernel 3.10.107 and I keep on getting some very strange messages when trying to start it:

The ubuntu version sends this

Code: Select all

./z-way-server: 1: ./z-way-server: xm: not found
./z-way-server: 1: ./z-way-server: ?m: not found
./z-way-server: 1: ./z-way-server: : not found
./z-way-server: 1: ./z-way-server: xm: not found
./z-way-server: 1: ./z-way-server: ??
                                    m?KMOQRUWX]_: not found
./z-way-server: 1: ./z-way-server: ELF: not found
./z-way-server: 2: ./z-way-server: Syntax error: ";" unexpected
The debian version gives me this:

Code: Select all

./z-way-server: 1: ./z-way-server: : not found
./z-way-server: 1: ./z-way-server: ??
                                    mA?JLMOPSUW[^_: not found
./z-way-server: 1: ./z-way-server: ELF: not found
./z-way-server: 4: ./z-way-server: Syntax error: ";" unexpected
What am I missing here?

User avatar
PoltoS
Posts: 4224
Joined: 26 Jan 2011 19:36

Re: Zway not starting on ubuntu

Post by PoltoS » 24 Jun 2018 09:00

Do file z-way-server; file /bin/ls

rafale77
Posts: 19
Joined: 23 Jun 2018 19:26

Re: Zway not starting on ubuntu

Post by rafale77 » 25 Jun 2018 10:30

When I run the command you gave I get this:
z-way-server: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.24, BuildID[sha1]=8ab3ac21a700ca8f677748d070debcb77b7062a5, not stripped
/bin/ls: ELF 64-bit LSB shared object, ARM aarch64, version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux-aarch64.so.1, for GNU/Linux 3.7.0, BuildID[sha1]=de05fcef79d88af9cf9a71ed38e73af0b179bfb2, stripped
It looks like the Ubuntu version of zway I downloaded was for x86-64 platform. What version do I need to pick for arm64? (aarch64?)
I also checked the raspberry pi version and it is an arm32 (armhf) platform.

User avatar
PoltoS
Posts: 4224
Joined: 26 Jan 2011 19:36

Re: Zway not starting on ubuntu

Post by PoltoS » 25 Jun 2018 19:48

Ha, you use x64 version in a Pi!

Use normal Raspberry Pi version

rafale77
Posts: 19
Joined: 23 Jun 2018 19:26

Re: Zway not starting on ubuntu

Post by rafale77 » 26 Jun 2018 00:40

Unfortunately the raspberry pi version I downloaded shows up as arm32. (Raspberrypixtool) I used the Ubuntu version because my OS/kernel is Ubuntu/Debian based. Are there multiple version of the raspberry pi?

rafale77
Posts: 19
Joined: 23 Jun 2018 19:26

Re: Zway not starting on ubuntu

Post by rafale77 » 26 Jun 2018 03:35

I figured it out by installing one by one each missing armhf (32bit) library on my arm64 Ubuntu. It was not too bad but I wish it was better documented. On arm platform (rasberry Pi) zway is only available on 32bit. This was on a pine64 with Armbian running on top of 64bit Ubuntu 18.04.

The libraries missing were libavahi-compatible-dnssd1, libssl, libarchive12, libc-ares-dev, libcurl3 and libcurl4 all needed with the :armhf appendix to get the 32bit version and obviously the 32bit platform had to be added to the 64bit OS.

MichaelBAL
Posts: 7
Joined: 17 Jun 2018 19:21
Location: Virgin Islands
Contact:

Zway not starting on ubuntu

Post by MichaelBAL » 31 Jul 2018 12:20

Yes, please keep it running. As it seems the problem is not with the scientific data but with some weird virtualbox stuff.

damian
Posts: 1
Joined: 06 Aug 2018 05:59

Re: Zway not starting on ubuntu

Post by damian » 06 Aug 2018 06:00

use x64 version in a Pi, normal Raspberry Pi version

rafale77
Posts: 19
Joined: 23 Jun 2018 19:26

Re: Zway not starting on ubuntu

Post by rafale77 » 08 Aug 2018 00:45

The normal Raspberry Pi version is actually a 32bit. There is no arm64 version. The only 64bit versions available are for x86 (windows and linux)

Post Reply