2.3.8. - Binding Problem - No Devices

Discussions about Z-Way software and Z-Wave technology in general
Toffi
Posts: 18
Joined: 12 Aug 2016 09:43

2.3.8. - Binding Problem - No Devices

Post by Toffi » 17 Oct 2018 22:18

I just installed 2.3.8. via the Smarthome GUI and after restart/reboot I don´t see any Z-wave devices anymore.

When going to Devices -> Z-Wave -> Manage I got the following error:

"An unexpected error occurred during loading data. Try to reload the page.

Please check
1.) if the controller is plugged in correctly,
2.) that in the app 'Z-Wave Network Access' the right port is entered
(UZB: '/dev/ttyACM0', RaZberry shield: '/dev/ttyAMA0', UZB-Windows: '\\.\COM3', Z-Stick: '/dev/ttyUSB0', embedded boxes: '/dev/ttyS0' or '/dev/ttyS1')
3.) the app is aktiv. If not you could activate it under Menu > Apps > Active or add a new one under Menu > Apps > Local.
The Setting 'Expert View' needs to be active under Menu > My Settings."

THe app "Z-Wave Network Access" is running and configured as before.
I tried reinstall the app an several restart, reboot but stiil the same. No access to the z-wave devices.

In Expert UI I got the following message when trying to enter Device -> Status or other:
"Communication or binding error! Please login again or check system connectivity."

Running z-way on a Razberry with Jessie.

Any idea?

Regards

Toffi
Posts: 18
Joined: 12 Aug 2016 09:43

Re: 2.3.8. - Binding Problem - No Devices

Post by Toffi » 17 Oct 2018 22:20

In the "Events" I finf this message:

Cannot start Z-Wave binding: ReferenceError: ZWaveBinding is not defined

Popp Wod
Posts: 30
Joined: 24 Oct 2016 23:19

Re: 2.3.8. - Binding Problem - No Devices

Post by Popp Wod » 17 Oct 2018 23:20

Same error for me
HW Popp hub v1 / Razberry 2
I tried to update from 2.3.6

Toffi
Posts: 18
Joined: 12 Aug 2016 09:43

Re: 2.3.8. - Binding Problem - No Devices

Post by Toffi » 18 Oct 2018 19:35

I just had a look into the log file:
Thats what happens after reboot:

Code: Select all

[2018-10-17 20:40:11.643] [I] [core] Rebooting system ...
[2018-10-17 20:40:17.335] [I] [core] Executing script: exit()
[2018-10-17 20:41:14.261] [I] [core] Executing script: /*** Z-Way Home Automation Engine main executable ***************************** ...
[2018-10-17 20:41:14.288] [I] [core] Executing script: // Comon utilities and functions ...
[2018-10-17 20:41:14.336] [I] [core] Executing script: // This script transforms old formats to new ...
[2018-10-17 20:41:25.644] [I] [core] Executing script: /*! EventEmitter2 https://github.com/hij1nx/EventEmitter2 Copyright (c) 2013 hij1nx Licensed under the MIT license.*/ ...
[2018-10-17 20:41:25.801] [I] [core] Executing script: //     Underscore.js 1.8.3 ...
[2018-10-17 20:41:25.989] [I] [core] Executing script: /*! Papa Parse v4.1.2 https://github.com/mholt/PapaParse */ ...
[2018-10-17 20:41:26.172] [I] [core] Executing script: /* @license zlib.js 2012 - imaya [ https://github.com/imaya/zlib.js ] The MIT License */ ...
[2018-10-17 20:41:26.292] [I] [core] Executing script: // BAOS_API_2011_01_29_001 ...
[2018-10-17 20:41:26.297] [I] [core] Executing script: // Converts IntelHex into binary 128 kB file ...
[2018-10-17 20:41:26.302] [I] [core] Executing script: // Public domain version of Base64 encoder/decoder found somewhere in the Internet ...
[2018-10-17 20:41:26.337] [I] [core] Executing script: //--------------------------------------------------------------------- ...
[2018-10-17 20:41:26.454] [I] [core] Executing script: /* ...
[2018-10-17 20:41:26.476] [I] [core] Executing script: /*** Z-Way HA Virtual Device base class *************************************** ...
[2018-10-17 20:41:26.499] [I] [core] Executing script: /*** Z-Way DevicesCollection class ************************************ ...
[2018-10-17 20:41:26.669] [I] [core] Executing script: /*** Z-Way HA Controller class module ***************************************** ...
[2018-10-17 20:41:26.695] [I] [core] Executing script: /*** Automation Webserver Auth Controller ************************************* ...
[2018-10-17 20:41:26.711] [I] [core] Executing script: /*** Z-Way HA Automation module base class ************************************ ...
[2018-10-17 20:41:26.720] [I] [core] Executing script: /*** Initialize Webserver and Handlers ***************************************** ...
[2018-10-17 20:41:26.755] [I] [core] Executing script: /*** ZAutomationAPI Web Request Handler ***************************************** ...
[2018-10-17 20:41:26.855] [I] [core] Executing script: /*** ZAutomationAPI Provider ************************************************** ...
[2018-10-17 20:41:26.863] [I] [core] Executing script: // Make this testable by pulling in underscore from the parent module ...
[2018-10-17 20:41:26.886] [I] [core] Executing script: /*** Main Automation storage module ***************************************** ...
[2018-10-17 20:41:26.973] [I] [core] --- Loading ZAutomation classes
[2018-10-17 20:41:27.899] [I] [core] Starting ZWay Automation webserver
[2018-10-17 20:41:28.298] [I] [core] Loading modules...
[2018-10-17 20:41:28.369] [I] [core] Loading module Cron from modules/Cron
[2018-10-17 20:41:28.377] [I] [core] Executing script: /*** Cron ZAutomation module ************************************************** ...
[2018-10-17 20:41:28.442] [I] [core] Instantiating module 2 from class Cron
[2018-10-17 20:41:28.452] [I] [core] --- Starting module System Clock (CRON)
[2018-10-17 20:41:28.610] [I] [core] Loading module ZWave from modules/ZWave
[2018-10-17 20:41:28.716] [I] [core] Executing script: /*** Z-Wave Binding module ******************************************************** ...
[2018-10-17 20:41:29.185] [I] [core] Instantiating module 1 from class ZWave
[2018-10-17 20:41:29.196] [I] [core] --- Starting module Z-Wave Network Access
[2018-10-17 20:41:30.231] [I] [core] ReferenceError: ZWaveBinding is not defined
[2018-10-17 20:41:30.235] [I] [core] Trying to restart Z-Wave binding (zway) in 10 seconds

User avatar
PoltoS
Posts: 4302
Joined: 26 Jan 2011 19:36

Re: 2.3.8. - Binding Problem - No Devices

Post by PoltoS » 20 Oct 2018 00:16

This means during the start some libraries are missing. Please check that you have the correct version of libssl.

Run Z-Way from the console to see which lib is missing

Zjohan
Posts: 9
Joined: 16 Dec 2014 21:29

Re: 2.3.8. - Binding Problem - No Devices

Post by Zjohan » 21 Oct 2018 19:59

I also got the same problem after upgrade from 2.3.6 to 2.3.8
I include some log information below.
Anyone that has found a solution to this?

[2018-10-21 18:48:56.511] [core] Restarting Z-Wave binding (zway)
[2018-10-21 18:48:56.514] [core] ReferenceError: ZWaveBinding is not defined
[2018-10-21 18:48:56.515] [core] Trying to restart Z-Wave binding (zway) in 10 seconds
[2018-10-21 18:49:06.519] [core] Restarting Z-Wave binding (zway)
[2018-10-21 18:49:06.531] [core] ReferenceError: ZWaveBinding is not defined
[2018-10-21 18:49:06.535] [core] Trying to restart Z-Wave binding (zway) in 10 seconds
[2018-10-21 18:49:16.528] [core] Restarting Z-Wave binding (zway)
[2018-10-21 18:49:16.530] [core] ReferenceError: ZWaveBinding is not defined
[2018-10-21 18:49:16.532] [core] Trying to restart Z-Wave binding (zway) in 10 seconds
[2018-10-21 18:49:26.526] [core] Restarting Z-Wave binding (zway)
[2018-10-21 18:49:26.528] [I] [core] ReferenceError: ZWaveBinding is not defined
[2018-10-21 18:49:26.528] [I] [core] Trying to restart Z-Wave binding (zway) in 10 seconds
[2018-10-21 18:49:36.528] [I] [core] Restarting Z-Wave binding (zway)
[2018-10-21 18:49:36.529] [I] [core] ReferenceError: ZWaveBinding is not defined
[2018-10-21 18:49:36.540] [I] [core] Tried 5 times without success. Stopping tries.
[2018-10-21 18:49:36.578] [I] [core] Notification: critical (z-wave): Cannot start Z-Wave binding: ReferenceError: ZWaveBinding is not defined
pi@raspberrypi ~ $
pi@raspberrypi ~ $
pi@raspberrypi ~ $
pi@raspberrypi ~ $ sudo /opt/z-way-server/z-way-server restart
/opt/z-way-server/z-way-server: error while loading shared libraries: libzcommons.so: cannot open shared object file: No such file or directory
pi@raspberrypi ~ $ sudo find / -name libzcommons.so
/opt/z-way-server_2018-10-21-18-43-48/libs/libzcommons.so
/opt/z-way-server_2016-04-29-22-13-56/libs/libzcommons.so
/opt/z-way-server_2015-09-03-18-51-55/libs/libzcommons.so
/opt/z-way-server_2017-05-03-21-01-55/libs/libzcommons.so
/opt/z-way-server_2017-01-28-13-33-36/libs/libzcommons.so
/opt/z-way-server_2015-07-08-09-49-27/libs/libzcommons.so
/opt/z-way-server_2017-10-27-19-00-45/libs/libzcommons.so
/opt/z-way-server_2017-08-19-12-15-49/libs/libzcommons.so
/opt/z-way-server_2015-12-27-14-35-13/libs/libzcommons.so
/opt/z-way-server/libs/libzcommons.so
/opt/z-way-server_2015-12-27-14-37-03/libs/libzcommons.so
/opt/z-way-server_2016-10-22-13-15-42/libs/libzcommons.so
/opt/z-way-server_2018-10-21-18-18-30/libs/libzcommons.so
pi@raspberrypi ~ $ ls -ltr /opt/z-way-server/libs/libzcommons.so
-rwxrwxr-x 1 pi pi 44700 Oct 10 00:36 /opt/z-way-server/libs/libzcommons.so
pi@raspberrypi ~ $ ls -ltr /opt/z-way-server_2018-10-21-18-18-30/libs/libzcommons.so
-rwxrwxr-x 1 pi pi 44660 Oct 4 2017 /opt/z-way-server_2018-10-21-18-18-30/libs/libzcommons.so
pi@raspberrypi ~ $

User avatar
PoltoS
Posts: 4302
Joined: 26 Jan 2011 19:36

Re: 2.3.8. - Binding Problem - No Devices

Post by PoltoS » 22 Oct 2018 08:59

Please enable remote support and send us access info on support@z-wave.me. we will check what is missing

Popp Wod
Posts: 30
Joined: 24 Oct 2016 23:19

Re: 2.3.8. - Binding Problem - No Devices

Post by Popp Wod » 23 Oct 2018 08:21

Email sent. Looking forward for you guys to identify the problem.

temp
Posts: 13
Joined: 27 May 2018 12:52

Re: 2.3.8. - Binding Problem - No Devices

Post by temp » 25 Oct 2018 11:10

Any News??

Popp Wod
Posts: 30
Joined: 24 Oct 2016 23:19

Re: 2.3.8. - Binding Problem - No Devices

Post by Popp Wod » 25 Oct 2018 17:36

I sent an email to support@z-wave.me as mentioned by Polto.
In addition to this I sent 2 bug reports out of the zway software.

Nobody contacted me yet nor accessed the system.

It's a real mess as downgrade to 2.3.7 or 2.3.6 is impossible and the system is almost bricked.
Any hint on how to downgrade to 2.3.6 any other way?
I am just a z-way user, so almost no knowledge in linux available...

Any help is appreciated.

Post Reply