Z-way server goes down spontaneously

Discussions about Z-Way software and Z-Wave technology in general
User avatar
PoltoS
Posts: 5286
Joined: 26 Jan 2011 19:36

Re: Z-way server goes down spontaneously

Post by PoltoS » 07 Feb 2020 02:28

Thanks for the crash log.

As for the "gap", is your HTTP request (http://192.168.1.3:1025/ZWave?Cmd=CBck& ... Lev=%VALUE% - the one on which it hanged on) running in async: true mode? If not, your main thread is hanging while waiting for the reply, so this http.request lead to webserver not being answer on time.

User avatar
GokMasE
Posts: 21
Joined: 13 Mar 2016 01:04

Re: Z-way server goes down spontaneously

Post by GokMasE » 07 Feb 2020 14:34

Ok thanks for pointing that out. Does the "gap" of silence also mean that the z-wave server is on some level locked as well since there seems to be no internal handling of z-wave data logged during this period of time either?

User avatar
PoltoS
Posts: 5286
Joined: 26 Jan 2011 19:36

Re: Z-way server goes down spontaneously

Post by PoltoS » 08 Feb 2020 10:57

There are few threads. All JS is in our thread only. Z-Wave is in another

User avatar
GokMasE
Posts: 21
Joined: 13 Mar 2016 01:04

Re: Z-way server goes down spontaneously

Post by GokMasE » 10 Feb 2020 00:22

I noticed something in one of the log files which got me thinking:

Code: Select all

[2020-02-06 01:13:56.840] [I] [core] http://192.168.1.3:1025/ZWave?Cmd=CBck&Dev=%DEVICE%&Lev=%VALUE% : ZWayVDev_zway_6-1-50-2 : 0.6 : http://192.168.1.3:1025/ZWave?Cmd=CBck&Dev=ZWayVDev_zway_6-1-50-2&Lev=0.6
[2020-02-06 01:13:56.873] [I] [core] http://192.168.1.3:1025/ZWave?Cmd=CBck&Dev=%DEVICE%&Lev=%VALUE% : ZWayVDev_zway_6-1-50-2 : 0.6 : http://192.168.1.3:1025/ZWave?Cmd=CBck&Dev=ZWayVDev_zway_6-1-50-2&Lev=0.6
[2020-02-06 01:13:56.900] [I] [core] http://192.168.1.3:1025/ZWave?Cmd=CBck&Dev=%DEVICE%&Lev=%VALUE% : ZWayVDev_zway_6-1-50-2 : 0.6 : http://192.168.1.3:1025/ZWave?Cmd=CBck&Dev=ZWayVDev_zway_6-1-50-2&Lev=0.6
[2020-02-06 01:13:56.925] [I] [core] http://192.168.1.3:1025/ZWave?Cmd=CBck&Dev=%DEVICE%&Lev=%VALUE% : ZWayVDev_zway_6-1-50-2 : 0.6 : http://192.168.1.3:1025/ZWave?Cmd=CBck&Dev=ZWayVDev_zway_6-1-50-2&Lev=0.6
[2020-02-06 01:13:56.972] [I] [core] Can not make request: Server returned nothing (no headers, no data)
[2020-02-06 01:13:56.973] [I] [core] Can not make request: Server returned nothing (no headers, no data)
[2020-02-06 01:13:56.973] [I] [core] Can not make request: Server returned nothing (no headers, no data)
[2020-02-06 01:13:57.165] [I] [core] Request was successful
Here it seems to me that the server is sending the exact same notification 4 times, which seems rather strange. A bug or some filtering missing?
It also sends them off quite rapidly (all 4 within 85ms) and only the last one of these transmissions is apparently considered successful.

Is the timeout value so short that the first 3 requests are considered timed out? Or will the server disregard any response that has not had time to arrive at the time that another HTTP request is sent? Or is something else causing this?

Thanks in advance,

Regards / Joakim

Wikibear
Posts: 96
Joined: 01 Jul 2016 14:10

Re: Z-way server goes down spontaneously

Post by Wikibear » 12 Feb 2020 20:45

@PoltoS i've installed the version you mentioned. Which logs do are you need now?
Greatings from the noob

User avatar
PoltoS
Posts: 5286
Joined: 26 Jan 2011 19:36

Re: Z-way server goes down spontaneously

Post by PoltoS » 13 Feb 2020 03:28

GDB logs. just before the crash with 1 2 3 4... (and 100 lines above)

Wikibear
Posts: 96
Joined: 01 Jul 2016 14:10

Re: Z-way server goes down spontaneously

Post by Wikibear » 18 Feb 2020 14:28

OK, i dont have a clue of GDB nerver hear before...
Greatings from the noob

User avatar
aLiEnHeAd
Posts: 79
Joined: 02 Feb 2017 15:09

Re: Z-way server goes down spontaneously

Post by aLiEnHeAd » 18 Feb 2020 15:41

Wikibear wrote:
18 Feb 2020 14:28
OK, i dont have a clue of GDB nerver hear before...
Have a look here:
viewtopic.php?f=3419&t=24693&hilit=gdb&start=14

rafale77
Posts: 44
Joined: 23 Jun 2018 19:26

Re: Z-way server goes down spontaneously

Post by rafale77 » 18 Feb 2020 19:02

I am not observing any of these crashes though I am very worried about this thread. Most seem to come from the rPi platforms. Is that correct?
Would be good for people to post what platform and version they are seeing this issue on.

Wikibear
Posts: 96
Joined: 01 Jul 2016 14:10

Re: Z-way server goes down spontaneously

Post by Wikibear » 26 Feb 2020 21:17

PoltoS you can force this issue with a stress test of HTTP API. Many requests from different sources in short time will destroy z-wave server immediately.

Try EDGE cause firefox gives me some bogus login errors... I can't fix this. Maybe EDGE force it down... Cause it happens often now via using with EDGE...

I see only this:

Code: Select all

3 0x714e0f10
4 0x714e0f20
5 0x3cf50
6
3 0x714e0f10
4 0x714ea1f8
5 0x3cf50
6
3 0x714ea1f8
4 0x714e0f20
5 0x3cf50
6
3 0x714e0f20
4 0x714e0ee0
5 0x3cf50
6
3 0x714e0ee0
4 0x714e1240
5 0x3cf50
6
3 0x714e1240
4 0x714b31b0
5 0x3cf50
6
3 0x714b31b0
4 0x714e1340
5 0x3cf50
6
3 0x714e1340
4 0x714e0e00
5 0x3cf50
6
3 0x714e0e00
4 0x714e0e70
5 0x3cf50
6
3 0x714e0e70
4 0x714e1360
5 0x3cf50
6
3 0x714e1360
4 0x714e0e30
5 0x3cf50
6
3 0x714e0e30
4 0x714e1330
5 0x3cf50
6
3 0x714e1330
4 0x714e1260
5 0x3cf50
6
3 0x714ea1f8
4 0x714e1330
5 0x3cf50
6
3 0x714ea1f8
4 0x714e0f10
5 0x3cf50
6
But that dont stop... API is not reachable and EDGE cannot show any pages of Smarthome UI...

Image

after time Thread running and website working but API is not reachable...
Greatings from the noob

Post Reply