Z-Way server does not report same value multiple times

Discussions about Z-Way software and Z-Wave technology in general
Post Reply
vinisz
Posts: 20
Joined: 23 Nov 2019 23:23

Z-Way server does not report same value multiple times

Post by vinisz » 06 Jan 2020 13:30

Hi All,

For logging purposes (InfluxDB/Grafana) , I want my fibaro FGMS-001 multisensor to report the temperature every 15 minutes, no matter if the temperature has changed or not.
I can do this by configuring parameter 64 to 900, which seem to wotk out fine.
however, when there is no change in temperature, I do see the device report it's value in the sniffer, but the Z-way gui events screen is not displaying this same value again, 15 minutes later.
It seems that z-way events screen is only displaying changes and is ignoring the same value reported again if it is unchanged.
As a result, I'm also not getting that value into node-red every 15 minutes when there is no change.

Expected behavior: Also display the event, even when there is no change.

I've attached two screenshots in which you can see that the same value is reported at 10:48 in the Zniffer, but there is no value vissible in the event monitor at 10:48 (because no change)
zwaysniffer.png
zwaysniffer.png (10.36 KiB) Viewed 445 times
zwaygui.png
zwaygui.png (20.91 KiB) Viewed 445 times

User avatar
PoltoS
Posts: 5286
Joined: 26 Jan 2011 19:36

Re: Z-Way server does not report same value multiple times

Post by PoltoS » 06 Jan 2020 23:03

If think it is somewhere here:
https://github.com/Z-Wave-Me/home-autom ... ce.js#L235

You can remove this check and get every value change.

vinisz
Posts: 20
Joined: 23 Nov 2019 23:23

Re: Z-Way server does not report same value multiple times

Post by vinisz » 07 Jan 2020 13:22

OK, I'm not a developper but can you make this an option in next version or something ? I really do not like to change code which might be overwritten in new versions.

User avatar
PoltoS
Posts: 5286
Joined: 26 Jan 2011 19:36

Re: Z-Way server does not report same value multiple times

Post by PoltoS » 08 Jan 2020 05:12

Well, this will produce quite a lot of useless traffic, i/o, events and might affect many aspects, so this is not something we can do for all users. I understand your frustration, but we need to think carefully and test before changing this.

platypus
Posts: 25
Joined: 28 Apr 2019 16:32

Re: Z-Way server does not report same value multiple times

Post by platypus » 09 Jan 2020 00:23

For data logging I use the app „sensor values logging“. It executes HTTP requests or saves to a JSON file every time a sensor updates, no matter if the actual value has changed. Maybe this could be an option for you?

vinisz
Posts: 20
Joined: 23 Nov 2019 23:23

Re: Z-Way server does not report same value multiple times

Post by vinisz » 10 Jan 2020 14:26

platypus wrote:
09 Jan 2020 00:23
For data logging I use the app „sensor values logging“. It executes HTTP requests or saves to a JSON file every time a sensor updates, no matter if the actual value has changed. Maybe this could be an option for you?
Thanks ! let me look into that...

Post Reply