Page 1 of 1

Daten nach Update bzw. Neuinstallation auf 3.x unbrauchbar

Posted: 14 Oct 2019 09:54
by Biker
Hallo,

nach dem Update auf Z-Way 3.x sind die zuvor gesicherten und zurück gelesen Daten des Controllers (auf dem Raspberry Pi 3 GPIO Steckplatz) nicht mehr zu gebrauchen. Hier eine Kurzbeschreibung der Problematik:

Ein Update von 2.xx auf 3.0.1 inkl. Jessie => Stretch/Buster war nicht erfolgreich (diverse Fehlermeldungen von Raspbian).

Daher habe ich Raspbian mit der aktuellen Version von https://www.raspberrypi.org/downloads/noobs/ neu aufgesetzt und anschließend Z-Way 3.0.1 https://z-wave.me/z-way/download-z-way/ installiert. Das lief ohne Probleme.

Ein Zugriff auf die GUI des Z-Way Systems war zu dem Zeiztpunkt möglich und es sah soweit alles gut aus. Da ich noch keine Rücksicherung der gemacht hatte, waren die Z-Wave Devices ohne weitere Information unter Geräte aufgeführt.

Nach der Rücksicherung der Daten herrscht nun aber totales Chaos. Die Anwendungen sind aufgeführt, das Dashboard ist leer und unter Geräte/Verwalten nur folgendes aufgeführt
Z-Way-01.jpg
Z-Way-01.jpg (44.58 KiB) Viewed 1303 times
Im Management findet sich unter Info ebenfalls Quatsch:
Z-Way-02.jpg
Z-Way-02.jpg (15.14 KiB) Viewed 1303 times
Firmwareupdate und Zurücksetzen in den Auslieferungszustand scheitern ebenfalls. Um den Fehler zu lokalisieren hatte ich am Wochenende den Raspberry vier mal neu aufgesetzt. In einem Fall konnte ich unter der ExpertUI zumindest die Geräte sehen und auch darauf zugreifen (scheint mit der Datensicherung mit/ohne Wiederherstellen des Z-Way Netzwerks zusammen zu hängen.

Da das Inkludieren der Geräte in ein zurück gesetztes System extrem viel Arbeit ist (überwiegend in Unterputzdosen verbaut) möchte ich ungern wieder bei Null anfangen.

Über Hinweise bin ich sehr dankbar.

Re: Daten nach Update bzw. Neuinstallation auf 3.0.1 unbrauchbar

Posted: 16 Oct 2019 18:25
by Arek
Ich habe das selbe.

Re: Daten nach Update bzw. Neuinstallation auf 3.x unbrauchbar

Posted: 17 Oct 2019 09:00
by Biker
Hallo,

nach vielem Hin und Her habe ich die Ursache gefunden und wie so oft ist es trivial. Das Problem ist der in der UI eingetragene Port des Controllers. Unter Anwendungen/Aktive Apps muss der serielle Port des Controllers angepasst werden. Für den GPIO Z-Wave Controller ist es /dev/ttyAMA0. Bei dem USB-Stick /dev/ttyACM0

Hinweise dazu habe ich hier gefunden: https://forum.z-wave.me/viewtopic.php?t=24707

Liebe Freunde von zwave.me: an der Dokumentation bzw. dem Support sollte ihr dringend arbeiten, damit Z-Wave endlich aus der Bastelecke kommt. Ich gehe davon aus, dass ein Großteil der User schon viel Geld in diese Lösung investiert haben und von daher mehr Professionalität erwarten dürfen.

Re: Daten nach Update bzw. Neuinstallation auf 3.x unbrauchbar

Posted: 21 Oct 2019 11:41
by Biker
Leider hatte ich mich zu früh gefreut, dern Eintrag des anderen Port war nur eine Teillösung. Nach zig Versuchen der Wiederherstellung bin ich wieder bei Null angefangen und habe die Geräte zurückgesetzt und neu Inkludiert.

Re: Daten nach Update bzw. Neuinstallation auf 3.x unbrauchbar

Posted: 23 Oct 2019 21:57
by ursk
Ja das Problem mit dem update ist leider gross.
Nach einigen Rettungsversuchen habe ich auch aufgegeben und beginne bei Null.
Will heissen:
Betriebssystem neu, z-wave 3.0, dann alle Sensoren inkludieren
und dann noch die ganze Logik neu machen.
Ist nicht wirklich toll!