Z-UNO: версия бутлоадера слишком новая

Данный раздел предназначен для русскоязычных пользователей. Если вы владеете английским, рекомендуем также просмотреть общую ветку обсуждений на английском.
Post Reply
warex
Posts: 5
Joined: 06 Sep 2016 09:01

Z-UNO: версия бутлоадера слишком новая

Post by warex » 03 Oct 2016 10:16

Здравствуйте, такая проблема. Купил несколько Z-uno.
Со старым поколением проблем нет, а из 3-х устройств нового поколения два не прошиваются. Ошибка:

Code: Select all

Z-Uno core version and device version mismatch. You have 0.6.7 firmware version on the board. Core version is 0.6.3. Please upgrade the bootloader.
Пытаюсь прошить бутлоадер, но получаю другую ошибку:

Code: Select all

Error  0	 There is no firmware "zuno_bootloader_AAAABBBB0115011000010043*.bin" that is needed for your Z-Uno
Ошибка при записи загрузчика
На сайте написано на этот счет следующее:
you are trying to update from some test version. To be able upgrade you need to downgrade first to the latest stable version and then install the desired version.
Но как сделать downgrade и потом install the desired version?

Спасибо

User avatar
PoltoS
Posts: 4302
Joined: 26 Jan 2011 19:36

Re: Z-UNO: версия бутлоадера слишком новая

Post by PoltoS » 03 Oct 2016 10:44

Лучше сразу 2.0.6 поставьте и обновите загрузчик. Downgrade делается установкой другой версии через board manager

warex
Posts: 5
Joined: 06 Sep 2016 09:01

Re: Z-UNO: версия бутлоадера слишком новая

Post by warex » 03 Oct 2016 12:24

Спасибо, все хорошо, обновился до 2.0.6

Post Reply