Cant access Razberry IP and GUI on razbarry zway

Discussions about RaZberry - Z-Wave board for Raspberry computer
Post Reply
tos79
Posts: 3
Joined: 02 Sep 2017 13:27

Cant access Razberry IP and GUI on razbarry zway

Post by tos79 » 02 Sep 2017 13:34

Hi,
I just installed the Razberry zwave module on my Pi3, I followed the installation instructions and everything went smoothly, however when i go to find.zwave.me, below the login screen it finds my razberry but when I click on it or manual type in the ip adress for access to the GUI, I just get an immidiate response that the connection is refused.

I tried reinstalling the Pi and Zwave but this does not work.
Need help, anyone got an idea what the problem could be?

vlad
Posts: 30
Joined: 19 Oct 2016 04:58

Re: Cant access Razberry IP and GUI on razbarry zway

Post by vlad » 02 Sep 2017 16:46

What is your RaspberryPi OS version? Jessie or stretch?

tos79
Posts: 3
Joined: 02 Sep 2017 13:27

Re: Cant access Razberry IP and GUI on razbarry zway

Post by tos79 » 03 Sep 2017 15:25

Hi I just found out it is stretch, how do I downgrade to jessie?

vlad
Posts: 30
Joined: 19 Oct 2016 04:58

Re: Cant access Razberry IP and GUI on razbarry zway

Post by vlad » 04 Sep 2017 00:51

you can install that additional lib like this:

wget http://mirrordirector.raspbian.org/rasp ... _armhf.deb
sudo dpkg -i libssl1.0.0_1.0.1t-1+deb8u6_armhf.deb

it will have some side effects of that some of ZWAVE modules will use 1.0 version the other standard library will use 1.0.2. I am testing it and it seems working for now.

Hopefully, next update of Zwave.me server will include correct build for Stretch.

tos79
Posts: 3
Joined: 02 Sep 2017 13:27

Re: Cant access Razberry IP and GUI on razbarry zway

Post by tos79 » 12 Sep 2017 10:32

Thanks for the help, it works now

MotoX
Posts: 2
Joined: 10 Sep 2017 16:32

Re: Cant access Razberry IP and GUI on razbarry zway

Post by MotoX » 12 Sep 2017 18:59

I have to say thank you as well vlad!

mr1
Posts: 2
Joined: 07 Oct 2017 12:00

Re: Cant access Razberry IP and GUI on razbarry zway

Post by mr1 » 07 Oct 2017 12:22

Does someone know, if it is possible somehow to force z-way-server to only use the old libcrypto.so.1.0.0 library instead of both the old libcrypto.so.1.0.0 and the new libcrypto.so.1.0.2 at the same time when running on stretch?

The z-way-server is basically still running after I upgraded my RPI from jessie to stretch, but unfortunately now it terminates every few hours with a SIGSEGV in libcrypto.so.1.0.2. Before the upgrade it ran stable for weeks. I guess this happens because of the mix of the two libraries. It seems to always happen when messages from a security enabled z-way device are processed.

Or is there something else I can do to prevent those crashes?

Because I have a lot of other things running on my RPI I don't want to downgrade it to jessie again only because of this.

vlad
Posts: 30
Joined: 19 Oct 2016 04:58

Re: Cant access Razberry IP and GUI on razbarry zway

Post by vlad » 09 Oct 2017 17:24

Unfortunately, until Z-Way will be compiled with new 1.0.2 library it doomed to run like this. Z-Way itself is referencing 1.0.0 but all other components from Stretch are using 1.0.2.

I have some side effects (like update console always shows an error - this has something to do with SSL stuff) but not that serious like crashing after few hours.

I was hopping that 2.3.6 version will have variant compiled for Stretch but looks like not dice so far...

mr1
Posts: 2
Joined: 07 Oct 2017 12:00

Re: Cant access Razberry IP and GUI on razbarry zway

Post by mr1 » 10 Oct 2017 19:24

I put the z-way-server now into an LXC container with a Debian Jessie file system that runs on my Debian Stretch RPi. This is not a very simple solution, but at least it seems to work for me again properly now until we hopefully get a better solution. (Probably running it using chroot on a Jessie file system would also work, but I did not try it.)

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 6 guests