Z-cloud and razberry

Discussions about RaZberry - Z-Wave board for Raspberry computer
mcfanda
Posts: 43
Joined: 08 Mar 2013 14:12

Z-cloud and razberry

Post by mcfanda » 08 Mar 2013 20:53

Hi
I have a raspberry pi with the Razberry z-wave module. Everything works fine and I managed to associate my fibaro z-divices to the controller and control them from the local webapp (:8083). Then I downloaded Z-connector and compiled it on RPI (it worked but one needs libargtable2-dev). I ran z-agent and it gets connected to the cloud (I see here on the left the green reassuring message). When I try to access the remote webapp, however, it says that my instance is not running. As I undestood that you need to be on the same computer than the z.agent, and my RPI is headless, I tried to connect to zwave.me:13535 via port forwarding through my RPI. In this way I get access to the webapp, but the loading gif goes on forever!
Any help will be great
marcello


User avatar
PoltoS
Posts: 4683
Joined: 26 Jan 2011 19:36

No, you don't need to be on

Post by PoltoS » 08 Mar 2013 20:53

No, you don't need to be on the same computer as the z-agent is to access.

You certianly have problem with TTY port - usually it is the most common problem with disconnecting z-agent. Also check logs - z-agent is certainly disconnecting all the time due to this.

mcfanda
Posts: 43
Joined: 08 Mar 2013 14:12

Hi, (thanks for the answer)

Post by mcfanda » 08 Mar 2013 20:53

Hi, (thanks for the answer)
I've looked at the logs and the --debug option, but I'm not sure what is going on. As you said, the agent seem to disconnect itself all the time, but the device is picked up. I'm attaching the log.
In a nutshell, it gets connected, loop starts, socket has data, Server has closed the connection, Socket has gone, Loop ended, and starts again.

Opening device...
[D] Configuring device...
[D] Creating a socket...
[D] Enabling keep-alives on the socket...
Connecting to server...
[D] Initialising OpenSSL environment...
[D] Allocating SSL context...
[D] Loading personal certificate...
[D] Loading personal certificate key...
[D] Loading CA certificate...
[D] Setting verification mode...
Establishing SSL connection...
[D] Allocating SSL session...
[D] Assigning socket...
Performing SSL handshake...
[D] Initialising SSL state...
[D] Sending handshake...
[D] Server has closed the SSL connection
[D] Shutting down SSL session...
[D] Freeing SSL session...
Establishing SSL connection...
[D] Allocating SSL session...
[D] Assigning socket...
Performing SSL handshake...
[D] Initialising SSL state...
[D] Sending handshake...
[D] Server has closed the SSL connection
[D] Shutting down SSL session...
[D] Freeing SSL session...
Establishing SSL connection...
[D] Allocating SSL session...
[D] Assigning socket...
Performing SSL handshake...
[D] Initialising SSL state...
[D] Sending handshake...
Loop started
[D] socket has data
[D] 5 bytes:
[D] 01 03 00 07 FB
[....................................................]
[D] Server has closed the connection
[E] Socket has gone
Loop ended
[D] Shutting down SSL session...
[D] Freeing SSL session...
[D] Freeing SSL context...
[I] Opening device...
[D] Configuring device...
[D] Creating a socket...
[D] Enabling keep-alives on the socket...
[I] Connecting to server...
[D] Initialising OpenSSL environment...


mcfanda
Posts: 43
Joined: 08 Mar 2013 14:12

Solved

Post by mcfanda » 08 Mar 2013 20:53

Hi
I've solved: on raspberry with razberry module one shouls kill the z-server that comes with the module. After that, z-connector works nicely

mcfanda
Posts: 43
Joined: 08 Mar 2013 14:12

Solved

Post by mcfanda » 08 Mar 2013 20:53

Hi
I've solved: on raspberry with razberry module one should kill the z-server that comes with the module. After that, z-connector works nicely

philbest
Posts: 4
Joined: 11 Apr 2013 19:50

Hello, I've the same problem

Post by philbest » 08 Mar 2013 20:53

Hello, I've the same problem but i don't undestand your issue ... How do you solve it ?
thanks .

User avatar
PoltoS
Posts: 4683
Joined: 26 Jan 2011 19:36

You need to turn off local Z

Post by PoltoS » 08 Mar 2013 20:53

You need to turn off local Z-Way: sudo /etc/init.d/Z-Way stop

tripp.carey
Posts: 1
Joined: 01 Jun 2013 06:30

Clarify Z-Way, Z-Cloud sync

Post by tripp.carey » 08 Mar 2013 20:53

So, am I reading this right that the local Z-Way does not sync with the Z-Cloud? You have to use either one or the other?

Thanks.

User avatar
PoltoS
Posts: 4683
Joined: 26 Jan 2011 19:36

Two different software can

Post by PoltoS » 08 Mar 2013 20:53

Two different software can not talk with one single COM port simultaneously. Z-Cloud is not related with local Z-Way software (though Z-Cloud is based on Z-Way). So, you need to choose one of them or plug a dongle for Z-Cloud to have both sticks in one network.

stivala
Posts: 1
Joined: 30 Jul 2013 11:01

have the same problem..

Post by stivala » 08 Mar 2013 20:53

hi i have the same problem, i shut down Z-way and problem still there... can anyone tell me how i can access logs? thanks

Post Reply