Mini Demo Code

Discussions about RaZberry - Z-Wave board for Raspberry computer
Post Reply
devauda
Posts: 15
Joined: 31 Dec 2012 16:37

Mini Demo Code

Post by devauda » 15 Mar 2013 10:41

I'm trying to use the Mini Demo Code on the razberry. As i don't have much experience in javascript, i thought the Mini Demo Code will be a good way to learn.
I downloaded the z-way-mini-ui-master folder from https://github.com/PoltoS/z-way-mini-ui/ on my client PC and started the z-way-demo.html file with my browser.
I then connected the Razberry with http://192.168.0.41:8083 without credentials, connection is ok, but nothing else... i only get the connection page and that's it...

http://ubuntuone.com/54kzYZEvgHDKmYgzP6hGJJ

Hope you can tell me what i'm doing wrong as it is a beginners problem.

Rgds,
Devauda

devauda
Posts: 15
Joined: 31 Dec 2012 16:37

No devices included

Post by devauda » 15 Mar 2013 10:41

Sorry for my question, i had nothing on the page because there were no zwave devices included on my z-way.
I included a sensor and it is better.

I still have a problem with the icons downloaded from the page (https://github.com/PoltoS/z-way-mini-ui ... pics/icons).
The .png files located in the /icons directory can't be opened. I tried with different viewers on both Windows and Linux, but it is still the same.

Then these images icons also seems to be corrupted on the web page. Have a look here:
http://ubuntuone.com/1n6vMIrCAZkgz6CRw99VaY

Thanks for your great work,
devauda

User avatar
PoltoS
Posts: 4991
Joined: 26 Jan 2011 19:36

Sure, these png files are

Post by PoltoS » 15 Mar 2013 10:41

Sure, these png files are symlinks ;) to ../current/.png
And current is a symlink to 24x24 folder (this is to allow easily switch to 16x16 icons).

Windows indeed do not support symlinks, so you have this problem. We will fix this in next release (you can also fork the project, do it and request for pull)

Post Reply