Home Automation - Backup/Restore

Discussions about RaZberry - Z-Wave board for Raspberry computer
Post Reply
pz1
Posts: 2053
Joined: 08 Apr 2012 13:44

Home Automation - Backup/Restore

Post by pz1 » 05 Jan 2015 13:41

Sofar I have added some 40 Home automation elements (coded devices, scenes, schedules, rules,..) For the backup I regularly make images of the SD card. I somehow have the feeling that this is not the most appropriate method for backup. Am I overlooking somthing, or...

Is there some kind of comprehensive backup mechanism in the development pipeline?
Since 29-12-2016 I am no longer a moderator for this forum

pz1
Posts: 2053
Joined: 08 Apr 2012 13:44

Re: Home Automation - Backup/Restore

Post by pz1 » 08 Jan 2015 22:13

Arghh.., Lost a whole bunch of scenes, schedules and rules on a system hanger of my Pi. Desparately need HA backup/restore.
Since 29-12-2016 I am no longer a moderator for this forum

pz1
Posts: 2053
Joined: 08 Apr 2012 13:44

Re: Home Automation - Backup/Restore

Post by pz1 » 10 Jan 2015 12:26

It looks like the HA settings are stored in:
configjson-06b2d3b23dce96e1619d2b53d6c947ec.json

Is it safe to restore that file to: z-way-server/automation/storage ?

Additional question:
In this json file I detected "ghost devices" i.e. two devices that no longer exist. They are RoundRobinScene_58, DummyDevice_62, and many LightSene_xx. All were removed at some time, and apparantly not cleanded up?

Can I fix that in some way?
Since 29-12-2016 I am no longer a moderator for this forum

User avatar
PoltoS
Posts: 4251
Joined: 26 Jan 2011 19:36

Re: Home Automation - Backup/Restore

Post by PoltoS » 13 Jan 2015 02:02

Yes, it is safe to restore this file.

pz1
Posts: 2053
Joined: 08 Apr 2012 13:44

Re: Home Automation - Backup/Restore

Post by pz1 » 15 Jan 2015 14:39

PoltoS wrote:Yes, it is safe to restore this file.
But unfortunately it does not seem to restore lost functionality. See: viewtopic.php?f=3422&t=21104
Since 29-12-2016 I am no longer a moderator for this forum

User avatar
PoltoS
Posts: 4251
Joined: 26 Jan 2011 19:36

Re: Home Automation - Backup/Restore

Post by PoltoS » 19 Jan 2015 21:50

Do it with server turned off

pz1
Posts: 2053
Joined: 08 Apr 2012 13:44

Re: Home Automation - Backup/Restore

Post by pz1 » 20 Jan 2015 15:55

pz1 wrote:In this configjson file I detected "ghost devices" i.e. two devices that no longer exist. They are RoundRobinScene_58, DummyDevice_62, and many LightSene_xx. All were removed at some time, and apparantly not cleanded up?

Can I fix that in some way?
In one of my previous posts I had this question about probably orphaned elements in the configjson file
Since 29-12-2016 I am no longer a moderator for this forum

Post Reply