Problem With Delayed Scene

Discussions about RaZberry - Z-Wave board for Raspberry computer
SolarFlor
Posts: 261
Joined: 22 Mar 2014 15:23

Problem With Delayed Scene

Post by SolarFlor » 12 Apr 2015 11:59

Hi All,
I would like that an event happen only after a certain time.

I believe that Delayed Scene is the right way to do it so I first create a Ligh Scene to turn off a light and it works very well.
Delayed Scene0.jpg
Delayed Scene0.jpg (22.65 KiB) Viewed 3745 times
After I tried to create a Delayed Scene but I was not able to select the above Ligh Scene I just created.
I can select all the old Light Scenes or even HTTP_devices but not the most recent Ligh Scene. Why?
Delayed Scene1.jpg
Delayed Scene1.jpg (18.93 KiB) Viewed 3745 times

pz1
Posts: 2053
Joined: 08 Apr 2012 13:44

Re: Problem With Delayed Scene

Post by pz1 » 12 Apr 2015 12:29

I think you have to restart thye controller to make that scene visible. That was at least necessary when I last played with it under 2.0.0.

SolarFlor
Posts: 261
Joined: 22 Mar 2014 15:23

Re: Problem With Delayed Scene

Post by SolarFlor » 12 Apr 2015 13:32

You are right.

After restart Delayed Scene is allowing me to select the right Ligh Scene I like to delay.
I have anoter question now.

Delayed Scene is asking me to select Scene that trigger timer start but I don't want to active the delay as consequence of a previous scene.

What I woul like to do is to active Delayed Scene within a Logical Rules. I mean when I have some conditions (or/and) than active Delayed Scene.

Any suggestion?
pz1 wrote:That was at least necessary when I last played with it under 2.0.0.
do you mean that this issue has been solved in a more recent version.

Which 'stable' version you suggest to load?
Ciao

pz1
Posts: 2053
Joined: 08 Apr 2012 13:44

Re: Problem With Delayed Scene

Post by pz1 » 12 Apr 2015 18:10

  • I don't know if the issue has been fixed in a later release, because I have not tried
  • Release candidate 25 is pretty stable (see sig)
  • You should be able to activate a delayed Scene in a rule. However you have to first create a DummyDevice next create a Scene (name it also Dummy) that sets this Dummy device. That scene can be called from your rule. It is a bit of a silly work-around. Let your delayed Scene be triggerd by this one. (must admit haven't tried it)
It might be worth to allow delayed scens be activated directly by rules as well. Let me know if/how this works.
Since 29-12-2016 I am no longer a moderator for this forum

SolarFlor
Posts: 261
Joined: 22 Mar 2014 15:23

Re: Problem With Delayed Scene

Post by SolarFlor » 12 Apr 2015 20:46

pz1 wrote:You should be able to activate a delayed Scene in a rule. However you have to first create a DummyDevice
Never done. Don't know how to do it
pz1 wrote:
It might be worth to allow delayed scens be activated directly by rules as well.
Definitly Yes.

I believe that Delayed Scene should be set without to define necessarly a Scene to activate it so that it could be used directly by rules.

It would be nice to have PoltoS view.

pz1
Posts: 2053
Joined: 08 Apr 2012 13:44

Re: Problem With Delayed Scene

Post by pz1 » 12 Apr 2015 21:05

Well, quite a long time ago the DelayedScene was made as a response on my request. The point was that in OpenRemote I had a button that switched off all lights. In order to avoid instabilities in the powerlines, I had made a OpenRemote macro which allowed a delay of a predefined number of milli seconds between the commands.
As this was rather cumbersome to achieve, and because I had more switches than there were LightScenes possible in Zway, I stopped using DelayedScenes. The DelayedScene module

By the way Create DummyDevice is easy:
In HA UI go to- Preferences/Modules/Devices. There select DummyDevice. Make it switch binary. That's all

pz1
Posts: 2053
Joined: 08 Apr 2012 13:44

Re: Problem With Delayed Scene

Post by pz1 » 12 Apr 2015 21:37

SolarFlor wrote:
pz1 wrote:
It might be worth to allow delayed scens be activated directly by rules as well.
Definitly Yes.
Requested Issue #235

n0ahg
Posts: 87
Joined: 08 May 2013 23:41

Re: Problem With Delayed Scene

Post by n0ahg » 13 Apr 2015 21:14

This is one of the reasons I wrote the DummyDevice, to fill gaps similar to the above across the board.

pz1
Posts: 2053
Joined: 08 Apr 2012 13:44

Re: Problem With Delayed Scene

Post by pz1 » 14 Apr 2015 09:49

pz1 wrote:Requested Issue #235
Well, apparantly this is not going to make it because of the complexity. Maybe the Recipe easyLogic that Dolpheen is presently making could help? (I haven't had the time to play with it yet)

dolpheen
Posts: 119
Joined: 10 Feb 2015 00:38

Re: Problem With Delayed Scene

Post by dolpheen » 14 Apr 2015 19:49

pz1 wrote:Maybe the Recipe easyLogic that Dolpheen is presently making could help? (I haven't had the time to play with it yet)
Yes, that's what is the eazyLogic for :) If you don't have enough power from basic logic modules but not ready to write your own standalone script or module.

SolarFlor, if you write what logic do you want (with exact devices for clarity) I can write an example for you. In eazyLogic it should not take more then a couple of couple lines )
Razberry B+ 2.0.1-rc25 on ZW500 + 15 devices / Razberry B 2.0.1-rc25 on ZW300 for test

Post Reply