2.2.0: CRON Error

Discussions about RaZberry - Z-Wave board for Raspberry computer
Spacerat
Posts: 56
Joined: 26 Dec 2015 21:03

Re: 2.2.0: CRON Error

Post by Spacerat » 18 Jan 2016 14:20

ridewithstyle wrote:And as I suspected, the schedules are executed according to the system time, in my case UTC. The GUI in Z-Way mislead me, because it displays UTC+1, so I figured this is the time to use. Once I used the UTC in schedules, they worked fine.
Did you enter the time now one hour earlier in the GUI?

How about setting the system time to UTC+1? Did you try this?

ridewithstyle
Posts: 72
Joined: 02 Jan 2016 01:20

Re: 2.2.0: CRON Error

Post by ridewithstyle » 18 Jan 2016 14:38

Yes, I set the times in the scheduler to UTC. I did'nt want to modify the raspberry system time, so this was the other option.

Greetings, rws

Spacerat
Posts: 56
Joined: 26 Dec 2015 21:03

Re: 2.2.0: CRON Error

Post by Spacerat » 25 Jan 2016 19:20

ridewithstyle wrote:Yes, I set the times in the scheduler to UTC. I did'nt want to modify the raspberry system time, so this was the other option.

Greetings, rws
I set the timezone with raspi-config and now it works fine.

ridewithstyle
Posts: 72
Joined: 02 Jan 2016 01:20

Re: 2.2.0: CRON Error

Post by ridewithstyle » 26 Jan 2016 00:56

Hi there,

nice hint! Tried it, will see if the schedule works accordingly tomorrow.

Regards, rws

User avatar
ronie
Posts: 58
Joined: 29 Jun 2015 09:50

Re: 2.2.0: CRON Error

Post by ronie » 26 Jan 2016 16:28

Hi guys,

sorry for that late answer.
In v2.2.0 there is a problem with the app formular of some apps that could only be instantiated once. E.g. 'Cron' - the app is still active (if it was already added) but the form that is responsible for editing and adding this app is broken.

This is fixed since v2.2.1-rc4. Also we've find out that the time format that you could enter in the apps 'Logical Rules', 'Scheduled Scene' and 'Smart Light' isn't working correctly. These fixes will be available soon via update in online app store and also (if released) in v2.2.1.

FYI:
As you have already correctly identified it is necessary to check the timezone of your box. Usually it comes with GMT +/-0 so it is necessary to add your timezone to get the correct timezone offset from the system. We will integrate this in smarthome ui in the near future. But meanwhile you could do the following things:

- like [Spacerat] via console at your box with command 'sudo raspi-config' -for more instructions please use this link : https://www.raspberrypi.org/documentati ... -config.md -headline: 'Internationalization Options'

- enter http://[IPOFYOURRASP]:8084 go to Advanced > System > Timezone and add your timezoneinfo there. You could google it or use this link http://pellepim.bitbucket.org/jstz/ (you will see it in the grey banner)

A restart isn't necessary.

If it doesn't work anyway please let us know. Thanks for your support.

BR ronie

pz1
Posts: 2053
Joined: 08 Apr 2012 13:44

Re: 2.2.0: CRON Error

Post by pz1 » 18 Feb 2016 13:10

Locked by moderator. Should be working in 2.2.1-rc4 and later.

Locked