A Beautiful Routing Table?

Discussions about RaZberry - Z-Wave board for Raspberry computer
marco
Posts: 64
Joined: 03 Dec 2015 19:50

A Beautiful Routing Table?

Post by marco » 27 Aug 2016 20:35

Is this a beautiful Routing Table?
Will it be reliable?
...
Attachments
RoutingTable.JPG
RoutingTable.JPG (293.62 KiB) Viewed 5083 times
Marco

User avatar
PoltoS
Posts: 4836
Joined: 26 Jan 2011 19:36

Re: A Beautiful Routing Table?

Post by PoltoS » 27 Aug 2016 21:27

WOWOWOW! You have really a lot of devices!

Looks pretty green ;)

A spoiler: we are working on new network statistics tool - it will be really helpful to improve network stability. We will release it this fall

marco
Posts: 64
Joined: 03 Dec 2015 19:50

Re: A Beautiful Routing Table?

Post by marco » 29 Aug 2016 23:29

This is the first step. We are going to install dedicated energy meters, humidity sensor, weather station ...cams...others... (but we do not want to reach limit number of nodes for a zwave mesh network for the moment)
Lot of trouble with V2.2.4-rc4 but since saturday afternoon every node is up. We are crossing fingers.
We hope in a fully reliable and stable release as soon as possible.
I'm ansious to give a look to your statistic tool...we have our idea on something similar.
Marco

marco
Posts: 64
Joined: 03 Dec 2015 19:50

Re: A Beautiful Routing Table?

Post by marco » 30 Aug 2016 23:26

Hi Poltos,
I give a look to your preliminary statistic tool on rc7. Not properly what we are thinking about but, of course, well done. Hold on.
Marco

marco
Posts: 64
Joined: 03 Dec 2015 19:50

Re: A Beautiful Routing Table?

Post by marco » 09 Sep 2016 06:37

That was a beautiful routing table.
Until yesterday morning everything was almost perfect. About 100 devices, all were working. UI was responsive, and commands propagated trough the mesh immediately. Battery device never worked like in this case. 15 magic days.
Yesterday we were forced to shut down the system for a couple of hours. When turned it ON again, only 4 devices were present and seems working. All others disappeared.
Tried to restore backup pre-shut down;
tried to reuse zway-server folder pre-shut down;
tried to reuse older backup and folder;
tried to upgrade firmaware version from v2.2.4-rc4 to v2.2.4-rc9
Is impossible to reach devices: even in expert UI there is no more trace of devices.
I can only see button that we manually pushed on wall but it seems that system do not recognize them.
Any Help?
Marco

User avatar
PoltoS
Posts: 4836
Joined: 26 Jan 2011 19:36

Re: A Beautiful Routing Table?

Post by PoltoS » 12 Sep 2016 02:31

More specific info will be appreciated:
1) Do you still see list of devices in Z-Way like pre-shutdown?
2) If yes, do you see them interviewed or not? Is NIF known to RaZberry (first + in the list of + +++ ++++ in Config tab)?
3) If yes, show the log of boot up (may be too long for me to read ;( ) and of the moment when you try to control some of devices

bawesto
Posts: 9
Joined: 05 Jan 2017 18:20

Re: A Beautiful Routing Table?

Post by bawesto » 05 Jan 2017 18:42

I have serios Problems with the Update-Function in the Routing Table.
Everytime I click Update for a Device, all Interview-Data from the Updated Device gets lost, all Elements in UI are gone.
I can reproduce this.
Devices to far from Hub can't be Reintervied an also Reinclusion doesn't work without bringing the Device closer to Hub.
Is there no one else having this Problem?

Hardware Raspberry 3b with new RaZberry Z-Wave-Plus Card, newest Version Z-Wave and UI (what you get from razberry.z-wave.me/install two weeks ago)

User avatar
PoltoS
Posts: 4836
Joined: 26 Jan 2011 19:36

Re: A Beautiful Routing Table?

Post by PoltoS » 06 Jan 2017 17:58

Devices should not loos interview just on routes update. Please show your log. Make sure to update routes of devices around RaZberry first and only then for others

bawesto
Posts: 9
Joined: 05 Jan 2017 18:20

Re: A Beautiful Routing Table?

Post by bawesto » 06 Jan 2017 23:25

Ok, here the Logfile.
LogfileInterviewLostOnUpdateRouting.zip
(3.07 KiB) Downloaded 117 times
I can reproduce it with any Type of Device i have.
The Device tested was an AEON Labs Gen5 Power Plug. It is close to Razpberry.

User avatar
PoltoS
Posts: 4836
Joined: 26 Jan 2011 19:36

Re: A Beautiful Routing Table?

Post by PoltoS » 07 Jan 2017 14:47

Some small part of log - no idea what happens. New node found, nothing special

Post Reply