Can't update Firmware

Discussions about RaZberry - Z-Wave board for Raspberry computer
diemue
Posts: 26
Joined: 09 Sep 2015 12:40

Re: Can't update Firmware

Post by diemue » 04 Dec 2016 22:41

Tried the same. But after upgrade to 2.2.5 i get alway the message "Could not retrieve data from remote serve" (http://IP:8083/expert/#/uzb)

Torulf
Posts: 10
Joined: 22 Nov 2015 11:42

Re: Can't update Firmware

Post by Torulf » 04 Dec 2016 23:43

@diemue
Did you run the bootloader and firmware update while in 2.1.2 before upgrading to 2.2.5?
I did a factory reset of the z-wave controller before all this. Be aware that this can fail. I have several Z-wave controllers and this i currently not my production unit so i could afford a failure.

Torulf
Posts: 10
Joined: 22 Nov 2015 11:42

Re: Can't update Firmware

Post by Torulf » 11 Dec 2016 13:47

Small followup on this topic.
After update to 5.16 i got instability issues in domoticz that uses openzwave. Previously it was fairly stable. Reverted back to 5.04 but for some reason it still does not work reliably in domoticz. With Z-way it is working fine.¨
All tests on raspberry pi 2 using Z-way image updated to 2.2.5 or latest release of domoticz on raspian jessie lite.

pz1
Posts: 2053
Joined: 08 Apr 2012 13:44

Re: Can't update Firmware

Post by pz1 » 11 Dec 2016 17:14

Torulf wrote:Do anyone know what was implemented between 5.06 and 5.16?
http://razberry.zwave.me/index.php?id=32
This is what my system says before I try to upgrade.
upgrade.PNG
upgrade.PNG (8.07 KiB) Viewed 4575 times
In another discussion I have suggested to first contact support@z-wave.me for advice!
They never publish what is in experimental features.

Torulf
Posts: 10
Joined: 22 Nov 2015 11:42

Re: Can't update Firmware

Post by Torulf » 11 Dec 2016 19:37

Wondering why the bootloader is different.
Attachments
zwave 504.JPG
504
zwave 504.JPG (21.32 KiB) Viewed 4573 times

pz1
Posts: 2053
Joined: 08 Apr 2012 13:44

Re: Can't update Firmware

Post by pz1 » 11 Dec 2016 21:46

I have no idea, except for the fact that I am running v2.3.0-rc1 and I had updated to firmware 5.06 a month ago or so.
Since 29-12-2016 I am no longer a moderator for this forum

pepeEL
Posts: 36
Joined: 05 Jan 2017 17:48

Re: Can't update Firmware

Post by pepeEL » 05 Jan 2017 18:05

TomasF wrote:I finally managed to update first the bootloader then the firmware in two steps. This is how I did it:
1: Fresh start with the razberry-2.2.2-rpi3.img. (from here http://razberry.z-wave.me/z-way-server/)
2: Some messing around trying to login. Unclear why I finally managed...
3: Cleaned my browser cache to get the web interface to work.
4: Expertmode->Network->Cardinfo->Firmware update
voila: Now I could update both the bootloader and the firmware to 5.04.
5: Restart using (Management->Firmware update -> update to latest->Advanced -> System->Reboot
6: Expertmode->Network->Cardinfo->Firmware update button no longer exist but
http://IP:8083/expert/#/uzb did
7: Boot loader ugrade to 8aaa and firmware to 5.16
However, I still read version 5.04 from the control info.
8: Update to version 2.2.5 and Power off cycle.
9: Update using http://IP:8083/expert/#/uzb (first bootloader then firmware)
10: Power cycle, now controller info shows 5.16.
11: Switched back to my original Rasbian distro. The network is still there.
(phuu...)

Now, I will evaluate the new firmware to see if my devices works better. The issue is that they do not relay to eachother. Or at lest I do not think they do...

Anybody can help me how i can go back to FW 5.04 ? I update by this manual firmware in my Razberry to version 5.16 and now it now working with my Domoticz. I only update FW with out bootloader. Please help me

Torulf
Posts: 10
Joined: 22 Nov 2015 11:42

Re: Can't update Firmware

Post by Torulf » 06 Jan 2017 01:27

Try update to v2.3.0-rc1 and se if you can downgrade from there. Tried some later build (rc2 or rc3) but newer got it stable then. I am using openhabian on my test device at the moment and dont remember all.

pepeEL
Posts: 36
Joined: 05 Jan 2017 17:48

Re: Can't update Firmware

Post by pepeEL » 06 Jan 2017 02:05

But how downgrade to v2.3.0-rc1 ?
In update i must write "v2.3.0-rc1" ?

pepeEL
Posts: 36
Joined: 05 Jan 2017 17:48

Re: Can't update Firmware

Post by pepeEL » 06 Jan 2017 12:45

Where i can download file with FW 5.04 to my Razberry GPIO to Rasperry?
I want write this file by programmer usb ch341A

Post Reply