Disabled function in v2.2.5?

Discussions about RaZberry - Z-Wave board for Raspberry computer
Post Reply
ClausE
Posts: 2
Joined: 18 Sep 2016 00:07

Disabled function in v2.2.5?

Post by ClausE » 05 Dec 2016 23:52

When upgrading from v2.2.4 to v2.2.5 some functions stopped working as expected.
1. I’m using the module send Email. (https://github.com/islipfd19/home-autom ... ules/Email) After upgrading and when trying to send a mail I get the fault message “Error during perform command execution: Error: This command is denied by policy”. When reverting back to an old backup and v2.2.4 everything is working correct again. Do I need to change anything to get the module working or is a bug in the new version?

2. I also have a Fibaro magic eye FGMS-001 V3.2 and at every battery polling (7200s) I get the motion detection alarm. I’m not absolutely sure if it is 100% consequent.

Unfortunately, I did not save any logs before reverting back to v2.2.4 (I had a complete Image+Zwave backup).
Have I done something wrong?.

User avatar
marco
Posts: 66
Joined: 03 Dec 2015 19:50

Re: Disabled function in v2.2.5?

Post by marco » 23 Dec 2016 17:52

Hi,
only for the point n 1, when you receive an error saying: "this command is denied by the policy" probably you are running an OS system call. To avoid this error you must specify the root of the command in the .syscommands file in the automation folder.
Marco

klaasjoerg
Posts: 126
Joined: 30 Sep 2016 23:49

Re: Disabled function in v2.2.5?

Post by klaasjoerg » 30 Dec 2016 00:33

Yes, that's correct. The file .syscommands is unfortunately always overwritten/replaced once you upgraded your zwave-installation. So I usually backup this file, before doing an upgrade...

Post Reply