Error after update to latest version

Discussions about RaZberry - Z-Wave board for Raspberry computer
Post Reply
ftrueck
Posts: 41
Joined: 24 Dec 2015 23:46

Error after update to latest version

Post by ftrueck » 30 Dec 2016 02:02

[2016-12-29 22:45:22.703] [core] Executing script: exit()
[2016-12-29 22:46:53.549] [core] Executing script: /*** Z-Way Home Automation Engine main executable ***************************** ...
[2016-12-29 22:46:54.023] [core] Executing script: // Comon utilities and functions ...
[2016-12-29 22:46:54.033] [core] Executing script: // This script transforms old formats to new ...
[2016-12-29 22:46:54.068] [E] [core] result: Error: SyntaxError: Unexpected token >
at automation/updateBackendConfig.js:4:16
at automation/updateBackendConfig.js:440:3
at automation/main.js:23:1
[2016-12-29 22:46:54.072] [E] [core] result: Error: Error: Uncaught SyntaxError: Unexpected token >
at Error (native)
at automation/main.js:23:1


z-way server is running and this error occours in /var/log/z-way-server.log.
I called the wget script to update and update was running fine so far.
But webif is not accessible anymore due to this error.

Has anyone else got this error?
Is there something to do to get it back working instead of switch back to older version?

User avatar
PoltoS
Posts: 4978
Joined: 26 Jan 2011 19:36

Re: Error after update to latest version

Post by PoltoS » 06 Jan 2017 18:28

looks you updateBackendConfig is corrupted

ftrueck
Posts: 41
Joined: 24 Dec 2015 23:46

Re: Error after update to latest version

Post by ftrueck » 17 Jan 2017 22:19

How can I fix that? And why does this happen?

User avatar
PoltoS
Posts: 4978
Joined: 26 Jan 2011 19:36

Re: Error after update to latest version

Post by PoltoS » 18 Jan 2017 04:02

no, looks more like config is corrupted. Please take config.json from some of your backup

Post Reply