Offline installation/use?

Discussions about RaZberry - Z-Wave board for Raspberry computer
Post Reply
pwm
Posts: 14
Joined: 27 Jan 2018 20:30

Offline installation/use?

Post by pwm » 28 Jan 2018 19:13

Is it possible to install and run completely offline from z-wave.me?

First off - I currently can't continue with install since the z-wave.me server just returns error 500.
Secondly - I don't want any reverse tunnel from my home to an unknown server.
Thirdly - I don't want said server to potentially store sensor information, apartment information etc.

I already have VPN tunnel functionality allowing me to remotely connect to whatever home applicance I want in a secure way.

Right now, I have been sitting with my Razberry for a week and can't get any progress.

Provo
Posts: 112
Joined: 19 Oct 2016 19:54

Re: Offline installation/use?

Post by Provo » 29 Jan 2018 08:48

Not sure about installing, but you can run it independently from z-wave.me. Remote access is an option in settings that can be turned on and off.

pwm
Posts: 14
Joined: 27 Jan 2018 20:30

Re: Offline installation/use?

Post by pwm » 29 Jan 2018 09:13

So my big trouble right now, is just to get my R-Pi to think it has local account information since the registration server is down?

Provo
Posts: 112
Joined: 19 Oct 2016 19:54

Re: Offline installation/use?

Post by Provo » 29 Jan 2018 16:37

When I installed, everything went smooth, so I can't really tell you. But are you sure it's not actually running? Check if the z-way-server service is up, and/or try entering 127.0.0.1:8083 in the address field on a web browser on your rpi.

pwm
Posts: 14
Joined: 27 Jan 2018 20:30

Re: Offline installation/use?

Post by pwm » 29 Jan 2018 20:39

z-way-server is most definitely running and serving data on port 8083.

It's just that it displays a login display and the error "The request failed because server does not responding".
And this seems to be the result of the failure to run /etc/init.d/zbw_autosetup start

zbw_autosetup fails with 500 Internal Server Error because the user registration page is down.

Seems to give same result if I visit the R-Pi and browse http://localhost:8083/ or if I try to reach http://<my-pi>:8083/

Post Reply