Raspberry Pi + Z-Way + RaZberry and LHC5020 association

Discussions about RaZberry - Z-Wave board for Raspberry computer
Post Reply
edge
Posts: 2
Joined: 11 Oct 2018 11:23

Raspberry Pi + Z-Way + RaZberry and LHC5020 association

Post by edge » 11 Oct 2018 11:50

Does anyone have any setup experience for LOGIC HOME CONTROL LHC5020 with Z-Way on Raspberry Pi with RaZberry card ?
The main problem is MultiChannelAssociation with Basic Report V1 (group 2) association.
I have to put Controller (probably device 1) into to Basic Report association groups in the endpoints to get outputs report status.
When I push switch (devices.2.instances.1) ON the Z-Way Controller show me the switch status is OFF, but in same time LHC5020 change voltage output from 0 to 24v.

There log report, after setup MultiChannelAssociation and switch turned ON - Reply not received before timeout for job (SwitchBinary Get)

[2018-10-05 13:00:28.395] [core] --- ZWayVDev_zway_2-1-37 performCommand processing: {"0":"on","1":{}}
[2018-10-05 13:00:28.395] [zway] Adding job: SwitchBinary Set
[2018-10-05 13:00:28.402] [zway] Adding job: SwitchBinary Get
[2018-10-05 13:00:28.403] [D] [zway] SENDING (cb 0x11): ( 01 0E 00 13 02 07 60 0D 00 01 25 01 FF 25 11 64 )
[2018-10-05 13:00:28.405] [D] [zway] RECEIVED ACK
[2018-10-05 13:00:28.409] [D] [zway] RECEIVED: ( 01 04 01 13 01 E8 )
[2018-10-05 13:00:28.409] [D] [zway] SENT ACK
[2018-10-05 13:00:28.409] [D] [zway] Delivered to Z-Wave stack
[2018-10-05 13:00:28.433] [D] [zway] RECEIVED: ( 01 07 00 13 11 00 00 02 F8 )
[2018-10-05 13:00:28.433] [D] [zway] SENT ACK
[2018-10-05 13:00:28.433] [zway] Job 0x13 (SwitchBinary Set): Delivered
[2018-10-05 13:00:28.434] [D] [zway] SendData Response with callback 0x11 received: received by recipient
[2018-10-05 13:00:28.434] [D] [zway] SETDATA devices.2.data.lastSendInternal = **********
[2018-10-05 13:00:28.434] [D] [zway] Job 0x13 (SwitchBinary Set): success
[2018-10-05 13:00:28.434] [zway] Removing job: SwitchBinary Set
[2018-10-05 13:00:28.468] [D] [zway] SENDING (cb 0x12): ( 01 0D 00 13 02 06 60 0D 00 01 25 02 25 12 99 )
[2018-10-05 13:00:28.473] [D] [zway] RECEIVED: ( 01 0D 00 04 00 02 07 60 0D 01 01 20 03 FF 42 )
[2018-10-05 13:00:28.473] [D] [zway] SENT ACK
[2018-10-05 13:00:28.474] [D] [zway] SETDATA devices.2.data.lastReceived = 0 (0x00000000)
[2018-10-05 13:00:28.474] [D] [zway] SETDATA devices.2.instances.1.commandClasses.32.data.level = 255 (0x000000ff)
[2018-10-05 13:00:28.474] [D] [zway] SETDATA devices.2.instances.1.commandClasses.37.data.level = True
[2018-10-05 13:00:28.479] [core] Notification: device-info (device-OnOff): {"dev":"Switch (2.1)","l":"on","location":""}
[2018-10-05 13:00:28.483] [D] [zway] RECEIVED CAN
[2018-10-05 13:00:28.493] [D] [zway] SENDING (cb 0x13): ( 01 0D 00 13 02 06 60 0D 00 01 25 02 25 13 98 )
[2018-10-05 13:00:28.500] [D] [zway] RECEIVED ACK
[2018-10-05 13:00:28.505] [D] [zway] RECEIVED: ( 01 04 01 13 01 E8 )
[2018-10-05 13:00:28.505] [D] [zway] SENT ACK
[2018-10-05 13:00:28.505] [D] [zway] Delivered to Z-Wave stack
[2018-10-05 13:00:28.550] [D] [zway] RECEIVED: ( 01 07 00 13 13 00 00 05 FD )
[2018-10-05 13:00:28.550] [D] [zway] SENT ACK
[2018-10-05 13:00:28.550] [zway] Job 0x13 (SwitchBinary Get): Delivered
[2018-10-05 13:00:28.551] [D] [zway] SendData Response with callback 0x13 received: received by recipient
[2018-10-05 13:00:28.551] [D] [zway] SETDATA devices.2.data.lastSendInternal = **********
[2018-10-05 13:00:28.551] [D] [zway] Job 0x13 (SwitchBinary Get): success
[2018-10-05 13:00:28.551] [zway] Waiting for job reply: SwitchBinary Get
[2018-10-05 13:00:30.674] [W] [zway] Reply not received before timeout for job (SwitchBinary Get)
[2018-10-05 13:00:30.958] [D] [zway] Job 0x13: deleted from queue
[2018-10-05 13:00:33.054] [D] [zway] RECEIVED: ( 01 0D 00 04 00 02 07 60 0D 01 00 25 03 00 B9 )
[2018-10-05 13:00:33.054] [D] [zway] SENT ACK
[2018-10-05 13:00:33.054] [D] [zway] SETDATA devices.2.data.lastReceived = 0 (0x00000000)
[2018-10-05 13:00:33.054] [D] [zway] SETDATA devices.2.instances.1.commandClasses.37.data.level = False
[2018-10-05 13:00:33.057] [core] Notification: device-info (device-OnOff): {"dev":"Switch (2.1)","l":"off","location":""}
[2018-10-05 13:00:33.176] [D] [zway] Job 0x13: deleted from queue

Any ideas ???

Best Regards,
Edge

Post Reply