SP814 motion detector

Discussions about existing Z-Wave device and their usage with Z-Way/Z-Cloud/Z-Box
Post Reply
pssara
Posts: 8
Joined: 01 Jun 2012 21:22

SP814 motion detector

Post by pssara » 10 Jun 2012 12:56

Hi,
I have installed a SP814 motion sensor. The device status on the webif changes to green when motion is detected. However, I cannot capture the event under a rule. I have tried event newvalue on, full, 99 but the rule is never triggered. Any suggestions?
Thanx

User avatar
PoltoS
Posts: 4268
Joined: 26 Jan 2011 19:36

Turn logging on and see what comes from the device

Post by PoltoS » 10 Jun 2012 12:56

Value is certainly 255 (full).

And make sure to enable associations. If you see colour changes, your device sends Reports, but not Set (called New Value in Rules). There should be a wat to enable Set too: by adding Z-Cloud to some association group or changing some config parameter.

pssara
Posts: 8
Joined: 01 Jun 2012 21:22

Hi, thanks for the reply.

Post by pssara » 10 Jun 2012 12:56

Hi, thanks for the reply.
The devices (I have got 2) are sending a set to the controller with a value of 99.


User avatar
PoltoS
Posts: 4268
Joined: 26 Jan 2011 19:36

In that case use Rule with parameters New Value 99

Post by PoltoS » 10 Jun 2012 12:56

And enable it with a checkbox on the left from the name of the Rule. Check logs to track the event.

eligv
Posts: 30
Joined: 08 Jun 2012 17:50

I have a sp814 Everspring

Post by eligv » 10 Jun 2012 12:56

I have a sp814 Everspring included in the network. This always idle. not activated LED detection. In interview appears complete configuration devices and device is currently sleeping.
Basic Level Set:
Updated: 13:19
Default value is unknown
This value is added to the BASIC command
Configuration parameter type is not handled in the interface: constant
Enable / Disable Function Detection Sensor:
Updated: 13:20
Default value is unknown
I tried changing the configuration commands in expert parameters 1 and 2 without success.

Any idea?

Eventually work!

Thanks and regards

klirichek
Posts: 39
Joined: 02 Nov 2012 14:53

It can be set via 'raw mode'

Post by klirichek » 10 Jun 2012 12:56

If you look into manual of sp814 you can see the config parameter 2, which enables or disables the sensor. Unfortunately I can't find the associated checkbox in the gui. But it is exist, and can be set in the raw mode.
Configuration, Set[2,1,1] will enable the sensor.
Configuration, Set[2,0,1] will disable it.

Also such param could be explicitly send via Expert mode commands (find there Configuration, Set Paramenter 2, value 1, 1 byte). BTW to make the change persistent it is necessary to be set in config.

And - since the device is battery powered - don't forget to wake it up (triple keypress) in order that these settings can be actually applied. Or wait when it wakes up itself (by default in 1 hour) and also take the settings.

eligv
Posts: 30
Joined: 08 Jun 2012 17:50

Thanks for the reply.

Post by eligv » 10 Jun 2012 12:56

Thanks for the reply.
Had already tried without success. I tested the detector with Vera or respond. Is the sensor problem.
Thanks again

Post Reply