Schlage lock and v2.3.8

Discussions about existing Z-Wave device and their usage with Z-Way/Z-Cloud/Z-Box
Post Reply
jswim788
Posts: 22
Joined: 12 Sep 2016 23:40

Schlage lock and v2.3.8

Post by jswim788 » 19 Nov 2018 22:01

I just installed v2.3.8 to try to solve a crash issue, but the new version doesn't work well with my Schlage BE469 locks. The main missing item is the reporting of the lock status when they are locked or unlocked at the keypad. Nothing is reported in the GUI or the history.

However, I can see that the lock is sending status in the logs so I know it is attempting to report something to the Z-way software. With version 2.3.6 I could use the Niffler and that worked well. However, Niffler seems to have been removed and/or doesn't work with v2.3.8.

Also, the v2.3.8 software sees this lock as a keypad, not as a lock. Could that be part of the problem? Regardless, it should report that the keypad lock and unlock happened even if it sees it as a keypad.

Any ideas on how to get this lock to work with v2.3.8? Is there a way to get Niffler to work with it?

kpanchen
Posts: 23
Joined: 08 Sep 2017 05:27

Re: Schlage lock and v2.3.8

Post by kpanchen » 26 Nov 2018 12:16

Same thing here, not sure how to make lock to report status, as I see it it will set proper status with open / lock through z-wave but won't change status after manual interaction.

Before I used "Periodical Door Polling" app and it was refreshing the interface but I realized that it is polling lock every minute waking it and lock battery drained in a week + tons of activity on the hub itself. Changing polling interval on the app don't work, it is still polling every minute.

Not sure what else to do.

kpanchen
Posts: 23
Joined: 08 Sep 2017 05:27

Re: Schlage lock and v2.3.8

Post by kpanchen » 27 Nov 2018 09:04

So basically just bumping the thread: after tons of reading I've eventually got to the point that functionality is basically missing, everything works as designed. Lock is sending Alarm event "0x71:6", controller handles the notification but does nothing after. I'm not sure why it was decided to exclude event 6 but in Zwave\index.js it is 5 goes to 7. Anyway it should be a fix in the code to rather do a device.get after receiving notification or event should be exposed. I'll try to see if I can mange to add some code but js is not my strong side. In case developers decided to help I'm more then willing to do any testing required.

Here're some reference threads:
https://forum.z-wave.me/viewtopic.php?p=68338
https://github.com/Z-Wave-Me/home-automation/issues/433
https://github.com/SphtKr/homebridge-zway/issues/108
https://github.com/Z-Wave-Me/home-automation/issues/422

UPD: After a more detailed look there's some related code in this section, I'll try to analyze it in more details to see if that's what we're looking for and why it doesn't work.

kpanchen
Posts: 23
Joined: 08 Sep 2017 05:27

Re: Schlage lock and v2.3.8

Post by kpanchen » 03 Dec 2018 11:46

UPD: Niffler works perfectly fine with the latest version and doing exactly what's needed, listening on Alarm command type 6 and issuing Get.

Post Reply