[userModule] SunriseSunset - No Longer Maintained

Tips, Tricks and Scripts to enhance your home automation and workaround known device bugs, limitations and incompatibilities
pz1
Posts: 2053
Joined: 08 Apr 2012 13:44

Re: [userMODULE] SunriseSunset - (Updated Dec 17, 2014)

Post by pz1 » 15 Jan 2015 00:19

Please note, there is this other userModule Daylight, which creates a day/night binary sensor. That sensor can be used in logical rules.
Since 29-12-2016 I am no longer a moderator for this forum

jet11x
Posts: 46
Joined: 29 Dec 2014 21:15

Re: [userMODULE] SunriseSunset - (Updated Dec 17, 2014)

Post by jet11x » 25 Jan 2015 16:29

In version 2.0.1-rc11 I don't see this module in the HA UI.
I believe that's because the module.json file lacks a category entry e.g.

Code: Select all

"category": "automation",

islipfd19
Posts: 126
Joined: 07 Jul 2014 03:35

Re: [userMODULE] SunriseSunset - (Updated Dec 17, 2014)

Post by islipfd19 » 01 Feb 2015 21:06

You're correct. I uploaded a newer version shortly after I updated to 2.0.0.

User avatar
PoltoS
Posts: 4251
Joined: 26 Jan 2011 19:36

Re: [userMODULE] SunriseSunset - (Updated Dec 17, 2014)

Post by PoltoS » 01 Feb 2015 22:52

May be better to place in same as Cron?

RottenMutt
Posts: 100
Joined: 31 Jan 2015 21:09

Re: [userMODULE] SunriseSunset - (Updated Dec 17, 2014)

Post by RottenMutt » 12 Feb 2015 06:08

I'm running v2.0.1-rc12 and can't get the plugin running after restarting z-wave...it doesn't show up under modules
i've followed the directions in the first post, and tried both directories.

/opt/z-way-server/automation/userModules/SunriseSunset

islipfd19
Posts: 126
Joined: 07 Jul 2014 03:35

Re: [userMODULE] SunriseSunset - (Updated Dec 17, 2014)

Post by islipfd19 » 13 Feb 2015 02:39

Did you upgrade the module or is it the version after upgrading ZWay? Try downloading the version in the first post. I made a change to the json file but didn't update the actual version numbers.

RottenMutt
Posts: 100
Joined: 31 Jan 2015 21:09

Re: [userMODULE] SunriseSunset - (Updated Dec 17, 2014)

Post by RottenMutt » 13 Feb 2015 04:43

it is the most recent and was the first time installing. i even matched the permissions to the included modules...

edit: I just tried logging in from another computer and it is there!!!

edit 2: the UI only allows the lights to be turned on before sunset, i would like after sunset. Same for Sunrise i would like to turn on the lights before sunrise. how about instead of zero, u add disabled to the drop down so zero can be a option. one other thing, instead of continuously check the time, why don't you set a one time cron event at the time you update sunrise and sunset (of coarse you would have to make and erase the events when the UI settings have been set/changed).

islipfd19
Posts: 126
Joined: 07 Jul 2014 03:35

Re: [userMODULE] SunriseSunset - (Updated Dec 17, 2014)

Post by islipfd19 » 14 Feb 2015 02:07

I could add parameters to turn the lights on before sunrise and sunset. I'd ahve to play around the json file to see if I can get disabled to be displayed instead of zero. Zway Cron module is not as robust as you think. I've tried many times to add/remove specific cron times for a different module without success. This was the best concept I was able to come up with. I've also noticed you can only have one sunrise / sunset module enabled. If you have more than one them enabled the module will turn on or off different light. The logic gets screwy. Just something I have to dig into when I have the time.

User avatar
Dude
Posts: 20
Joined: 21 Aug 2014 23:49

Re: [userMODULE] SunriseSunset - (Updated Dec 17, 2014)

Post by Dude » 30 Mar 2015 00:59

Hi,

I am using 2.0.1-rc22 and the Sunrise Module from the beginning of the post. The problem is that the userModule did not show up in the Modules section (or anywhere else). My log file is as follows:

Code: Select all

[2015-03-29 23:04:29.915] [I] [core] Loading module SunriseSunset from userModules/SunriseSunset
[2015-03-29 23:04:29.919] [D] [zway] RECEIVED ACK
[2015-03-29 23:04:29.919] [D] [zway] RECEIVED: ( 01 04 01 62 00 98 )
[2015-03-29 23:04:29.919] [D] [zway] SENT ACK
[2015-03-29 23:04:29.920] [D] [zway] SETDATA devices.22.data.isFailed = False
[2015-03-29 23:04:29.920] [I] [zway] Job 0x62 (Check if node is failed): Node 22 is operating
[2015-03-29 23:04:29.920] [D] [zway] Job 0x62 (Check if node is failed): success
[2015-03-29 23:04:29.920] [I] [zway] Removing job: Check if node is failed
[2015-03-29 23:04:29.920] [D] [zway] SENDING: ( 01 04 00 41 01 BB )
[2015-03-29 23:04:29.923] [I] [core] Executing script: /*** SunriseSunset Z-Way HA module 
Any ideas?

islipfd19
Posts: 126
Joined: 07 Jul 2014 03:35

Re: [userMODULE] SunriseSunset - (Updated Dec 17, 2014)

Post by islipfd19 » 31 Mar 2015 01:09

Did you attempt to try to download the zip file again? It was updated and works for 2.0.0.

Post Reply