Heating control bug

This is a collection of wishes and needs for the next versions of Z-Way/Z-Cloud/Z-Box
Post Reply
Posts: 1
Joined: 29 Oct 2017 13:05

Heating control bug

Post by samuel_k » 14 Nov 2018 22:57

I ran into a heating control bug on 2.3.8. The thermostat is a Danfoss Living Connect Z, adjusting the temperature has always worked fine, but it appears as though the heating control module seems to do something that isn't supported by the thermostat and then everything goes south.

Code: Select all

[2018-11-14 20:49:48.763] [I] [core] ---  ZWayVDev_zway_9-0-67-1 performCommand processing: {"0":"exact","1":{"level":"19"}}
[2018-11-14 20:49:48.765] [D] [zway] SETDATA devices.9.instances.0.commandClasses.67.data.1.setVal = 19.000000
[2018-11-14 20:49:48.767] [D] [zway] Job 0x13 (ThermostatSetPoint Set): removing duplicate
[2018-11-14 20:49:48.769] [D] [zway] Job 0x13 (ThermostatSetPoint Get): removing duplicate
[2018-11-14 20:49:48.773] [I] [zway] Node 9:0 CC ThermostatMode: Thermostat Mode 1 is not supported by device (modemask 0x0)
[2018-11-14 20:49:48.780] [I] [core] Notification: error (module): Error during perform command execution: Error: Invalid argument
[2018-11-14 20:49:48.798] [I] [core] Error: Invalid argument
    at Error (native)
    at t_vDev.(anonymous function).self.controller.devices.create.handler (automation/modules/ZWave/index.js:5448:61)
    at _.extend.performCommand (automation/classes/VirtualDevice.js:312:25)
    at Heating.performChangesOnThermostats (automation/modules/Heating/index.js:723:16)
    at automation/modules/Heating/index.js:602:38
    at Array.forEach (native)
    at automation/modules/Heating/index.js:601:41
    at Array.forEach (native)
    at self.vDev.self.controller.devices.create.handler (automation/modules/Heating/index.js:550:27)
    at _.extend.performCommand (automation/classes/VirtualDevice.js:312:25)

Posts: 6
Joined: 24 Jan 2017 20:42

Re: Heating control bug

Post by KanG » 18 Oct 2019 00:51

Any update?
HAve you fixed it? I think that also causes issue with homebridge and IOS13...

User avatar
Posts: 5286
Joined: 26 Jan 2011 19:36

Re: Heating control bug

Post by PoltoS » 08 Nov 2019 03:50

This should not be a problem

Post Reply