Page 1 of 1

Heating control bug

Posted: 14 Nov 2018 22:57
by samuel_k
I ran into a heating control bug on 2.3.8. The thermostat is a Danfoss Living Connect Z, adjusting the temperature has always worked fine, but it appears as though the heating control module seems to do something that isn't supported by the thermostat and then everything goes south.

Code: Select all

[2018-11-14 20:49:48.763] [I] [core] ---  ZWayVDev_zway_9-0-67-1 performCommand processing: {"0":"exact","1":{"level":"19"}}
[2018-11-14 20:49:48.765] [D] [zway] SETDATA devices.9.instances.0.commandClasses.67.data.1.setVal = 19.000000
[2018-11-14 20:49:48.767] [D] [zway] Job 0x13 (ThermostatSetPoint Set): removing duplicate
[2018-11-14 20:49:48.769] [D] [zway] Job 0x13 (ThermostatSetPoint Get): removing duplicate
[2018-11-14 20:49:48.773] [I] [zway] Node 9:0 CC ThermostatMode: Thermostat Mode 1 is not supported by device (modemask 0x0)
[2018-11-14 20:49:48.780] [I] [core] Notification: error (module): Error during perform command execution: Error: Invalid argument
[2018-11-14 20:49:48.798] [I] [core] Error: Invalid argument
    at Error (native)
    at t_vDev.(anonymous function).self.controller.devices.create.handler (automation/modules/ZWave/index.js:5448:61)
    at _.extend.performCommand (automation/classes/VirtualDevice.js:312:25)
    at Heating.performChangesOnThermostats (automation/modules/Heating/index.js:723:16)
    at automation/modules/Heating/index.js:602:38
    at Array.forEach (native)
    at automation/modules/Heating/index.js:601:41
    at Array.forEach (native)
    at self.vDev.self.controller.devices.create.handler (automation/modules/Heating/index.js:550:27)
    at _.extend.performCommand (automation/classes/VirtualDevice.js:312:25)