Page 1 of 1

Improve performance

Posted: 06 Jun 2019 18:28
by fez
I am "still" using version 2.3.8 with roughly 50 devices and a good set of rules (apps) to achieve some level of automation. Everything works fine, but there is a leg in the system which is getting to an uncomfortable level.
Basically rules are processed with roughly 1 second delay. For i.e. motion trigger, manual scene activation, etc. the "real time" feeling is not there anymore.
I believe this not so bad with fewer devices and apps.

I imagine there is no easy way to speed up the system, but maybe some priority options could be added.
Much of the action doesn't have to happen real time (i. e. scheduled stuff).

I tried to resolve most of what is possible with z-wave association (no gateway interaction), but that has it's limits also.

Re: Improve performance

Posted: 07 Jun 2019 11:54
by enbemokel
Hi fez,
did you check your history and disable moduls or functions of products you donĀ“t need?
Or, are you able to check with zniffer your network, there is often a lot of traffic that is not needed.

Re: Improve performance

Posted: 10 Jun 2019 22:49
by PoltoS
You should consider to use the latest Pi version 3 as it is much faster than 1 and 2. If you are also doing it, then you should check what is making delays - may be some particular app is introducing the delay.

Re: Improve performance

Posted: 11 Jul 2019 17:34
by fez
What would be the simplest way to analyze this?
Any recommendation on how to check what might be causing delays?

Re: Improve performance

Posted: 13 Jul 2019 12:52
by piet66
You could use my MxTools/CronDelays.html viewtopic.php?f=3419&t=31609#p81905 to check, if you have delays >= 1 Minute.