compile error zuno

Discussion about Z-Uno product. Visit http://z-uno.z-wave.me for more details.
Post Reply
bertr
Posts: 4
Joined: 02 Aug 2016 18:44

compile error zuno

Post by bertr » 02 Aug 2016 19:07

Hi there,
Bought a zuno, paired it with a zwave net work an that works fine.

Than i installed arduino IDE 1.6.5, loaded de simple blink sketch.
but when i try to compile and upload it to de Zuno, the arduino IDE gives an error:

compiler.exe: error: unrecognized arguments: pc\AppData\Roaming\Arduino15\packages\Z-Uno\hardware\zw8051\0.6.7 pc\AppData\Roaming\Arduino15\packages\Z-Uno\tools\zuno_toolchain\00.02.10/zuno_toolchain/sdcc/bin/

What do i do wrong :oops:

greetz Bert

p0lyg0n1
Posts: 168
Joined: 04 Aug 2016 07:14

Re: compile error zuno

Post by p0lyg0n1 » 04 Aug 2016 07:30

Hi, Bert. Looks like something is wrong with IDE parameters. Can you please enable verbose mode during compiling/uploading(see preferences of IDE) and post the full output there.

bertr
Posts: 4
Joined: 02 Aug 2016 18:44

Re: compile error zuno

Post by bertr » 04 Aug 2016 10:38

Hi p0lyg0n1,

thanks for your reaction.
Here it is:

Arduino: 1.6.5 (Windows 8.1), Board: "Z-Wave>ME Z-Uno, Europe, Disabled"

C:\Users\bertjes pc\AppData\Roaming\Arduino15\packages\Z-Uno\tools\zuno_toolchain\00.02.10/zuno_toolchain/compiler build C:\Users\BERTJE~1\AppData\Local\Temp\build1991647929483164784.tmp/SimpleBlink.cpp -r C:\Users\bertjes pc\AppData\Roaming\Arduino15\packages\Z-Uno\hardware\zw8051\0.6.7 -p C:\Users\bertjes pc\AppData\Roaming\Arduino15\packages\Z-Uno\tools\zuno_toolchain\00.02.10/zuno_toolchain/sdcc/bin/ -o -mmcs51 --out-fmt-ihx --model-large --verbose --debug --use-stdout --code-loc 0x8000 --xram-loc 0x3000

usage: compiler.exe [-h] {size,build,prog,boot,erase,readnvm} ...
compiler.exe: error: unrecognized arguments: pc\AppData\Roaming\Arduino15\packages\Z-Uno\hardware\zw8051\0.6.7 pc\AppData\Roaming\Arduino15\packages\Z-Uno\tools\zuno_toolchain\00.02.10/zuno_toolchain/sdcc/bin/
C:\Users\bertjes returned 2

Error compiling.

p0lyg0n1
Posts: 168
Joined: 04 Aug 2016 07:14

Re: compile error zuno

Post by p0lyg0n1 » 04 Aug 2016 13:38

You have a "space" inside path to your working folder. C:\Users\bertjes pc\AppData\Roaming\Arduino15\packages\Z-Uno\tools\zuno_toolchain\00.02.10/zuno_toolchain/sdcc/bin/ Quick fix is to rename your working directory or user(the most simple way is to rename your user or create a new one...). We will fix it in the next versions and add support for spaces in the working path for Windows.

bertr
Posts: 4
Joined: 02 Aug 2016 18:44

Re: compile error zuno

Post by bertr » 05 Aug 2016 12:23

thanks for finding the problem.

For now i will create a work around.

Thanks

Bert

Post Reply