Cannot find endpoint map to instance for Command Class

Discussion about Z-Uno product. Visit http://z-uno.z-wave.me for more details.
Post Reply
WernerS
Posts: 12
Joined: 07 Oct 2016 20:09

Cannot find endpoint map to instance for Command Class

Post by WernerS » 16 Nov 2016 12:17

Hello

i try different examples, but they dont work correctly with Openhab.
Example
When i switch the Fiabro FGS222 on i see in Openhab that Switch is on. With the zuno i see nothing. When i press a switch on a Port i dont see this in Openhab

Now i try the Water Sensor and i have installed openzwave control panel. So i see all the Communication.
The Zuno send some Information but there is the Error
"Error, Node038, Cannot find endpoint map to instance for Command Class OMMAND_CLASS_SENSOR_MULTILEVEL endpoint 0"
What is a endpoint and what is the error here?

Here the communictaion from the Fibaro and the zuno

Fibaro
2016-11-15 20:41:23.290 Detail, Node002, Received: 0x01, 0x09, 0x00, 0x04, 0x00, 0x02, 0x03, 0x25, 0x03, 0x00, 0xd5
2016-11-15 20:41:23.291 Detail,
2016-11-15 20:41:23.291 Info, Node002, Received SwitchBinary report from node 2: level=Off
2016-11-15 20:41:23.292 Detail, Node002, Refreshed Value: old value=true, new value=false, type=bool
2016-11-15 20:41:23.292 Detail, Node002, Changes to this value are not verified
2016-11-15 20:41:23.293 Detail, Node002, Notification: ValueChanged
2016-11-15 20:41:23.294 Info, Notification: Value Changed Home 0xee12f9a2 Node 2 Genre user Class SWITCH BINARY Instance 1 Index 0 Type bool


zuno
2016-11-15 20:41:39.280 Detail, Node038, Received: 0x01, 0x0f, 0x00, 0x04, 0x00, 0x26, 0x09, 0x60, 0x0d, 0x01, 0x01, 0x31, 0x05, 0x02, 0x01, 0x27, 0xa6
2016-11-15 20:41:39.281 Detail,
2016-11-15 20:41:39.281 Info, Node038, Received a MultiChannelEncap from node 38, endpoint 1 for Command Class COMMAND_CLASS_SENSOR_MULTILEVEL
2016-11-15 20:41:39.282 Info, Node038, Received SensorMultiLevel report from node 38, instance 2, General: value=39%
2016-11-15 20:41:39.282 Detail, Node038, Refreshed Value: old value=98, new value=39, type=decimal
2016-11-15 20:41:39.283 Detail, Node038, Changes to this value are not verified
2016-11-15 20:41:39.283 Detail, Node038, Notification: ValueChanged
2016-11-15 20:41:39.284 Info, Notification: Value Changed Home 0xee12f9a2 Node 38 Genre user Class SENSOR MULTILEVEL Instance 2 Index 2 Type decimal


2016-11-15 20:41:39.300 Detail, Node038, Received: 0x01, 0x0f, 0x00, 0x04, 0x00, 0x26, 0x09, 0x60, 0x0d, 0x00, 0x01, 0x31, 0x05, 0x02, 0x01, 0x27, 0xa7
2016-11-15 20:41:39.301 Detail,
2016-11-15 20:41:39.301 Error, Node038, Cannot find endpoint map to instance for Command Class COMMAND_CLASS_SENSOR_MULTILEVEL endpoint 0
node = 38 id = 1 value = 98 precision = 0
node = 38 id = 2 value = 39 precision = 0


kind regards
Werner

User avatar
PoltoS
Posts: 4946
Joined: 26 Jan 2011 19:36

Re: Cannot find endpoint map to instance for Command Class

Post by PoltoS » 26 Nov 2016 12:23

As I got from OpenHAB developers, they require each sketch to have an individual template to handle it. This is quite pitty as it is totally agains Z-Wave interoperable and plug&play style.

Post Reply