Unstable power from the Z-uno?

Discussion about Z-Uno product. Visit http://z-uno.z-wave.me for more details.
Post Reply
perjar
Posts: 16
Joined: 08 Apr 2018 18:02

Unstable power from the Z-uno?

Post by perjar » 18 May 2018 16:05

Hi,

Wanted to check with the community if you have encountered the same as I have: unstable output from the Z-uno when driven by USB power supply.

I am doing a small project similar to the example project "IR to Z-Wave":
https://z-uno.z-wave.me/examples/IR2ZWave/

My TSOP 7000 sensor prefers 5V so I attached mine to the 5V output instead of 3.3V, apart from that it was the same circuitry as in the example project.

I found that the IR sensor did not seem to be able to capture the IR signals from my remote control unless I pointed it straight at the sensor. This was not at all how other electronic equipment in the room reacted to the same remote control. Other devices responded to the remote no matter in which direction I was pointing it.

I was convinced there was a problem with my TSOP, too low sensitity or something.

As a last resort I tried the recommended design according to the TSOP data sheet, putting a capacitor between Vs and GND.
TSOP circuit.png
TSOP circuit.png (24.51 KiB) Viewed 632 times
And, suddenly, the IR sensor picks up the signals very well! No issues at all!

This was, I have to admit, a bit of a surprise, because the datasheet says that the capacitor is there to suppress disturbances from the power supply,

I can't be sure of course, but I think that the USB-chargers I amusing are good ones (they can't all be defective) and the Z-uno has no trouble running on its power. The question then is: is the Z-uno meddling with the 5V and 3.3V outputs and introduces disturbancies or what could be the issue you think?

Have anyone seen this too? If so, how have you dimesioned your capacitor? I am using 4.7 uF beacus it says so in the datasheet, but I have seen other sizes as well when browsing various projects in the web.

Thanks
Per

gabvoir
Posts: 5
Joined: 26 Jun 2017 21:34

Re: Unstable power from the Z-uno?

Post by gabvoir » 08 Jul 2018 00:32

Hello,

I think that I have the same problem.
I use a TouchClamp Click Mikroe based on MPR121 and supplied with 3.3V.
However it seem that the MPR121 does not react the same way if its supplied from computer USB or a charger.
I supposed that my charger deliver an approximative 5v and z-uno fails to straighten.

Could you inform me if the power circuit is the same for USB supply and direct 5v pin ?
Maybe can I test the proper functioning of the MCP1700 DC-DC converter ?

Thank you for helping

Frenchy Gab

michap
Posts: 313
Joined: 26 Mar 2013 10:35
Contact:

Re: Unstable power from the Z-uno?

Post by michap » 08 Jul 2018 20:16

@gabvoir :interesting...
I use the 3.3V for many different devices - simple sensores and sensors with integrated uC - never have expected such problems.

Can you try to define the voltage at 3.3V - is it stable?
Additional you can add a capacitor to the 3.3V output to eleminate any peaks - depending on the needed power it could be as sample 10..22uF.

Michael

p0lyg0n1
Posts: 157
Joined: 04 Aug 2016 07:14

Re: Unstable power from the Z-uno?

Post by p0lyg0n1 » 10 Jul 2018 14:51

So, as you can see here http://z-uno.z-wave.me/technical/power-supply/ Z-Uno uses Shottkey Diodes to avoid backward current to your USB and to regulators. Every diode drops about 0.2-0.3V on its own in the direct way. You have just about 5.0V(It depends on your USB source, many charges gives 5.5V)-0.3V =4.7V, and you also have about 3.0V on 3v3 pin. After the voltage the main characteristic of your sensor is a current that your sensor needs. You could use about 400mA for 5V pin and only 70-80mA for 3v3 pin.
Another feature of USB-power supply without an data-connection(you just use charger) is that the core of Z-Uno works 2 time faster all the time, cause it try to connect to full-speed USB all the time. That means that speed of every Software-based buses (I2c, 1wire, dht) will be 2 times faster too. If you use 5V pin to power up the Z-Uno it will be in "normal" mode instead of "boost mode" and all will be on base speed.
But, anyway, IR have to work. Could you sniff diagram from its output using a logic analyzer?

gabvoir
Posts: 5
Joined: 26 Jun 2017 21:34

Re: Unstable power from the Z-uno?

Post by gabvoir » 28 Jul 2018 13:46

michap wrote:
08 Jul 2018 20:16
Can you try to define the voltage at 3.3V - is it stable?
The output 3.3V from z-uno supplied by computer or by usb charger is always 3.06V, with or without charge on my sensor.
michap wrote:
08 Jul 2018 20:16
Additional you can add a capacitor to the 3.3V output to eleminate any peaks - depending on the needed power it could be as sample 10..22uF.
My TouchClamp Click seems to use 29µA.
What capacitor should I use? And could you confirm that I have to put between 3.3 and ground ?
p0lyg0n1 wrote:
10 Jul 2018 14:51
So, as you can see here http://z-uno.z-wave.me/technical/power-supply/ Z-Uno uses Shottkey Diodes to avoid backward current to your USB and to regulators. Every diode drops about 0.2-0.3V on its own in the direct way. You have just about 5.0V(It depends on your USB source, many charges gives 5.5V)-0.3V =4.7V, and you also have about 3.0V on 3v3 pin. After the voltage the main characteristic of your sensor is a current that your sensor needs. You could use about 400mA for 5V pin and only 70-80mA for 3v3 pin.
What's really weird is that everything works properly by supplying with computer, and not a USB charger.
p0lyg0n1 wrote:
10 Jul 2018 14:51
But, anyway, IR have to work. Could you sniff diagram from its output using a logic analyzer?
What does IR mean ?

To complete, I tried with an external power supply, to supply z-uno et sensor independently, and it's exactly the same.

Thank you for helping

p0lyg0n1
Posts: 157
Joined: 04 Aug 2016 07:14

Re: Unstable power from the Z-uno?

Post by p0lyg0n1 » 29 Jul 2018 00:02

Hi,
I have wrote about IR(InfraRed controller) to Per. He have started this topic first.
So, what is the problem with MPR121? Could you wrote some details? I don't have this device, but looks like it uses I2C communication. What library do you use for this? May be you have software problems that look like a power issue?

gabvoir
Posts: 5
Joined: 26 Jun 2017 21:34

Re: Unstable power from the Z-uno?

Post by gabvoir » 14 Aug 2018 15:21

Oups sorry, I reuse this topic, beacause it seems to be the same problem.
Exact, MPR121 use I2C communication.
I use this tutorial from chipkit and the library from Adafruit MP121 that I have personalize to use auto config.
The problem is that MPR121 return fake touched state.

I suppose it's a power issue because all is right when z-uno is powered by computer.
p0lyg0n1 wrote:
10 Jul 2018 14:51
Another feature of USB-power supply without an data-connection(you just use charger) is that the core of Z-Uno works 2 time faster all the time, cause it try to connect to full-speed USB all the time. That means that speed of every Software-based buses (I2c, 1wire, dht) will be 2 times faster too. If you use 5V pin to power up the Z-Uno it will be in "normal" mode instead of "boost mode" and all will be on base speed.
Maybe can i force to be in "boost mode" ?

Thank you for helping

Post Reply