z-uno module stops working when USB is not connected

Discussion about Z-Uno product. Visit http://z-uno.z-wave.me for more details.
Post Reply
samsonbox
Posts: 16
Joined: 06 Sep 2016 22:42

z-uno module stops working when USB is not connected

Post by samsonbox » 29 Jun 2019 01:24

Hello together,

I have a problem with the z-uno module. I have connected the USB_DP, USB_DM and GND to a USB cable. The VCC andGND is connected to a 3.3V power supply (as depiced in the reference). Pin 13 is wired to a LED (including a fitting resistor). With this setup i can reach the module via USB.I can program it and I can my serial outputs via USB. The LED is flashing also. Everthing fine. But as soon as I disconnect the USB cable from my pc the scatch stops e.g the LED stops flashing, and it remains either on or off. When I plug in the USB cable again, the LED continous flashing. So what have I done wrong? Do I need any pull up/down resistors on the USB pins? For me it looks like the device ist trapped in a USB-ISR. Has anyone an idea? Or would it be possible to post a reference design?

Thank you for your answers

samsonbox
Posts: 16
Joined: 06 Sep 2016 22:42

Re: z-uno module stops working when USB is not connected

Post by samsonbox » 02 Jul 2019 19:01

Ok I have a few more information about my problem:
1) the z-uno module is really alive and just trappen in something. I implemented a counteron the serial port and it just stops counting when I plug of the USB cable and continous counting when the cable ispluged in again.
2) WhenI plug off the USB calbe the D+ is HIGH and the D- is low which compiles with a USB-Highspeed deviec.
3) The 22Ohm inline resistors on D+/- and the 10kOhm pullup resistor on D+ are ok.
4) I also tried the same sketch on an normal z-uno and it woks fine. On the Module it doesn't work even with the new released toolkit 2.1.5
5) If I pull the D+ down to GND with an 10kOhm or if I pull D- up to 3,3V with a 10kOhm the sketch continous working.

Can anybody comment on these findings? Is my chip broken?

Thank you

rumen33
Posts: 4
Joined: 11 Sep 2016 22:45

Re: z-uno module stops working when USB is not connected

Post by rumen33 » 15 Jul 2019 20:25

The same problem observed. When USB_DM is pulled up to +3.3V (after the programming!) by 10kOhm resistor the sketch works properly.

samsonbox
Posts: 16
Joined: 06 Sep 2016 22:42

Re: z-uno module stops working when USB is not connected

Post by samsonbox » 16 Jul 2019 22:42

rumen33 wrote:
15 Jul 2019 20:25
The same problem observed. When USB_DM is pulled up to +3.3V (after the programming!) by 10kOhm resistor the sketch works properly.
That is what I did as well now. Do you have anSUB connector on your module? Or just headers? I have the suspicion that the chip does something strange. You can observe the identical behaviour if just plugin an USB cabe an a Z-Uno board put some osziprobeson thr D+ and D- pin. Strang

Post Reply