2.1.5 - failing to load sketch

Discussion about Z-Uno product. Visit http://z-uno.z-wave.me for more details.
Post Reply
Cyberax
Posts: 12
Joined: 15 Apr 2019 10:00

2.1.5 - failing to load sketch

Post by Cyberax » 03 Jul 2019 06:23

Hi!

Since upgrading a board to 2.1.5 I'm consistently getting CRC errors while uploading a sketch. Only about 5% of uploads work, if that. Tried with various security levels, frequences, multi-command settings. Tried recovery mode - same result.

I tried different USB cables and for some of my cables the board is not even registering as a USB serial device (it gets power, though).

Errors look like this:

Code: Select all

Openning port                            ..............................
Openning port                            ..............................                            OK


RAW Info: 
 AA AA BB BB 01 15 01 10
 00 01 02 0F 7B 5E B5 79
 02 7F C6 62 83 7F FF 7F
 FC 01 15 02 0F 4C A3 01
 03 16 12 FF FF FF FF FF
 FF FF FF FF FF FF FF FF
 FF FF FF FF FF FF FF FF
 FF FF FF FF FF FF FF FF
 FF FF FF 0F 11 06 0A 0B
 16 01 F3 00 02 1E
----------------------------------------------------------
                     FIRMWARE DATA                        
----------------------------------------------------------
	REVISION:02.15
	Z-WAVE FREQUENCY:US
	ORIGINAL FW. CRC32: 7B 5E B5 79
	MAXIMUM CODE SIZE: 30 KB
	CURRENT  FW. CRC16: 4C A3
	RADIO CHANNELS: 02
----------------------------------------------------------
                     HARDWARE DATA                        
----------------------------------------------------------
	CALIBRATION
		MAIN:03 TX: 16 12
	DEVICE PUBLIC KEY:
		HEX: 8D AC 75 87 8C 1E D4 9D 27 6A 61 EE D1 EC 8D D6 1A EF 70 C6 DA C5 AE 3F 84 26 96 36 93 9E C7 26
		DEC: 36268-30087-35870-54429-10090-25070-53740-36310-06895-28870-56005-44607-33830-38454-37790-50982
----------------------------------------------------------
                     PRODUCTION DATA                      
----------------------------------------------------------
	YOUR ZUNO S/N: 0F 11 06 0A 0B 16 01 00 02
----------------------------------------------------------
	PRODUCTION TIME:
		WEEK:15 YEAR:2017
	WORKSTATION:
		NUMBER:1 SEQUENCE:2838 
	HARDWARE:
		CHIP:1546 REVISION:2
----------------------------------------------------------

Writing NVM data                         [>                                                 ] (0%)
Writing NVM data                         [=================================================>] (99%)
Writing NVM data                         ..............................                            OK
          Sketch crc16:5ff9 size:118d (4.39 kB)

Pushing sketch                           .............................. 


			 ****    ****     ****      ****    ****    * 
			 *       *   *    *   *    *    *   *   *   * 
			 *       *   *    *   *    *    *   *   *   * 
			 ****    ***      ***      *    *   ***     * 
			 *       *  *     *  *     *    *   *  *      
			 ****    *   *    *   *     ****    *   *   * 



Error  0	 Can't upload sketch! Something went wrong. Bad CRC16 :'( .

Reseting chip                            ..............................
Reseting chip                            ..............................                            OK

Closing port                             ..............................
Closing port                             ..............................                            OK
ELAPSED:1.18378901482s

User avatar
PoltoS
Posts: 5093
Joined: 26 Jan 2011 19:36

Re: 2.1.5 - failing to load sketch

Post by PoltoS » 10 Jul 2019 00:54

Hello!

We have solved this - please remote the package from Arduino IDE, remove the z-uno files in staging folder and install the package again. Should solve the problem!

Post Reply