Error handling data from server

Discussions about RaZberry - Z-Wave board for Raspberry computer
SolarFlor
Posts: 261
Joined: 22 Mar 2014 15:23

Error handling data from server

Post by SolarFlor » 07 Mar 2015 01:34

Hi,
yesterday I had a blackout and when the power came back the Razberry stopped to work.

Raspberry is still working (I have other codes running) but when I run http://192.168.1.22:8083/expert/#/ i see the following message Error handling data from server.

Of course all automations are not working any more.

How I could check if the problem is in the RaZberry or in some files corrupted?
Thanks for your support

SolarFlor
Posts: 261
Joined: 22 Mar 2014 15:23

Re: Error handling data from server

Post by SolarFlor » 07 Mar 2015 15:27

I have also replaced the Raspberry but still not working. At this point I strongly believe that is the RaZberry board that failed.

dolpheen
Posts: 119
Joined: 10 Feb 2015 00:38

Re: Error handling data from server

Post by dolpheen » 07 Mar 2015 15:34

What version do you use?
1. You can make a backup of your z-way-server directoy and reinstall it (your user data should remain unchanged after re-installation).
2. You can change /etc/init.d/z-way-server
Remove

Code: Select all

> /dev/null 2>&1
in the 'start)' section and see what is logged on start z-way-server to console.
3. Also you can provide a /var/log/z-way-server.log for inspection
Razberry B+ 2.0.1-rc25 on ZW500 + 15 devices / Razberry B 2.0.1-rc25 on ZW300 for test

SolarFlor
Posts: 261
Joined: 22 Mar 2014 15:23

Re: Error handling data from server

Post by SolarFlor » 07 Mar 2015 16:07

Hi dolpheen,
my RaZberry is an old version (3rd generation I believe).
Not sure what you mean at point 1 and 2.

below the last lines in the log files

Code: Select all

[2015-03-07 13:19:32.154] [I] [core] Loading module Notification from modules/Notification
[2015-03-07 13:19:32.169] [I] [core] Executing script: /*** Notification Z-Way HA module ******************************************* ...
[2015-03-07 13:19:32.171] [I] [core] Loading module ImportRemoteHA from modules/ImportRemoteHA
[2015-03-07 13:19:32.186] [I] [core] Executing script: /*** ImportRemoteHA Z-Way HA module ******************************************* ...
[2015-03-07 13:19:32.199] [I] [core] Loading module TagOnOff from modules/TagOnOff
[2015-03-07 13:19:32.203] [I] [core] Executing script: /*** TagOnOff Z-Way HA module ******************************************* ...
[2015-03-07 13:19:32.206] [I] [core] Loading module CodeDevice from modules/CodeDevice
[2015-03-07 13:19:32.221] [I] [core] Executing script: /*** CodeDevice Z-Way HA module ******************************************* ...
[2015-03-07 13:19:32.224] [I] [core] Loading module LightScene from modules/LightScene
[2015-03-07 13:19:32.240] [I] [core] Executing script: /*** LightScene Z-Way HA module ******************************************* ...
[2015-03-07 13:19:32.242] [I] [core] Starting automation...
[2015-03-07 13:19:32.473] [I] [core] Starting storage...
[2015-03-07 13:19:32.485] [I] [core] ZWay Automation started

SolarFlor
Posts: 261
Joined: 22 Mar 2014 15:23

Re: Error handling data from server

Post by SolarFlor » 07 Mar 2015 16:29

dolpheen wrote: 2. You can change /etc/init.d/z-way-server
Remove

Code: Select all

> /dev/null 2>&1
in the 'start)' section and see what is logged on start z-way-server to console.
done but I don't remember how to stop start z-way from the console

dolpheen
Posts: 119
Joined: 10 Feb 2015 00:38

Re: Error handling data from server

Post by dolpheen » 07 Mar 2015 16:36

Not sure what you mean at point 1 and 2.
I meant to install a razberry dist (with version you have before).
Ex.

Code: Select all

wget -q -O - razberry.z-wave.me/install/v2.0.0 | sudo bash
done but I don't remember how to stop start z-way from the console

Code: Select all

sudo /etc/init.d/z-way-server stop

Code: Select all

sudo /etc/init.d/z-way-server start
As from you log, I see that server is started.

What do you have on http://192.168.1.22:8083/?
What is console output for 'netstat -a' command while z-way-server is running?
Razberry B+ 2.0.1-rc25 on ZW500 + 15 devices / Razberry B 2.0.1-rc25 on ZW300 for test

SolarFlor
Posts: 261
Joined: 22 Mar 2014 15:23

Re: Error handling data from server

Post by SolarFlor » 07 Mar 2015 16:42

This is what I can see when I start Z-way after editing the /etc/init.d/z-way-server

Code: Select all

root@raspberrypi:/opt/z-way-server# sudo /etc/init.d/z-way-server stop
Stopping z-way-server: done.
root@raspberrypi:/opt/z-way-server# sudo /etc/init.d/z-way-server start
Starting z-way-server: done.
root@raspberrypi:/opt/z-way-server# Z-Way version v2.0.0 from 2014-12-08 19:54:26 +0300 (build a064f5408850947aed035bc9170e1fa04f0fd2ec)
Looking for modules in ./modules
Module modws.so loaded
Module modenocean.so loaded
Module modzwave.so loaded
Module moddhs.so loaded
Module modhomekit.so loaded
cURL 7.26.0 likely has DNS timeout bug. Please update cURL. Disabling sync DNS timeouts for now.
Module modhttp.so loaded
Using default configuration file config.xml
Error: 'debug-port' number is out of range. Skipping it.

dolpheen
Posts: 119
Joined: 10 Feb 2015 00:38

Re: Error handling data from server

Post by dolpheen » 07 Mar 2015 16:47

SolarFlor wrote:This is what I can see when I start Z-way after editing the /etc/init.d/z-way-server
Looks like everything is OK. ('debug-port' error is not related to your problem)
Razberry B+ 2.0.1-rc25 on ZW500 + 15 devices / Razberry B 2.0.1-rc25 on ZW300 for test

SolarFlor
Posts: 261
Joined: 22 Mar 2014 15:23

Re: Error handling data from server

Post by SolarFlor » 07 Mar 2015 17:06

dolpheen wrote: I meant to install a razberry dist (with version you have before).
Ex.

Code: Select all

wget -q -O - razberry.z-wave.me/install/v2.0.0 | sudo bash
Done but during the loading of the code the following meessage appeared

Code: Select all

Err http://mirrordirector.raspbian.org wheezy Release.gpg
  Could not connect to mirrordirector.raspbian.org:80 (5.153.225.207), connection timed out
When try to open UI Expert
Attachments
Presentazione1.jpg
Presentazione1.jpg (21.5 KiB) Viewed 4222 times

SolarFlor
Posts: 261
Joined: 22 Mar 2014 15:23

Re: Error handling data from server

Post by SolarFlor » 07 Mar 2015 17:14

I have repeated the download and everything were ok without error messages (maybe it was a problem with internet).
Anyway still the system is not working
"Error Handling data from server"

Post Reply