Support for Buster?

Discussions about RaZberry - Z-Wave board for Raspberry computer
Post Reply
Atomic
Posts: 1
Joined: 28 Jun 2019 20:31

Support for Buster?

Post by Atomic » 28 Jun 2019 20:36

Currently, Z-Way FW updates do not work on Buster, as mongoose is compiled against a very old version of libssl.
Even "tricking" by modifying /etc/init.d/mongoose to use the provided old libssl library only works partially ("header to large")

LD_LIBRARY_PATH="/opt/z-way-server/libs/:${LD_LIBRARY_PATH}"
export LD_LIBRARY_PATH

fez
Posts: 93
Joined: 20 Jul 2015 23:03

Re: Support for Buster?

Post by fez » 08 Jul 2019 01:46

So no Raspberry Pi 4 with Z-Way?

User avatar
PoltoS
Posts: 4738
Joined: 26 Jan 2011 19:36

Re: Support for Buster?

Post by PoltoS » 08 Jul 2019 16:04

Early Aug

fez
Posts: 93
Joined: 20 Jul 2015 23:03

Re: Support for Buster?

Post by fez » 11 Jul 2019 02:39

I tried a fresh install of the version 3.0.0-rc31 on a raspberry 4 with the buster.
It actually works, until I uploaded my z-way backup (zab) made on the version 2.3.8.
Restoring the backup in expert mode worked fine.

Is this kind of migration (loading a 2.3.8 backup onto the 3.0.0) supported ?
Or better upgrade first the 2.3.8 to 3.0.0, create a backup and only then migrate?

User avatar
PoltoS
Posts: 4738
Joined: 26 Jan 2011 19:36

Re: Support for Buster?

Post by PoltoS » 14 Jul 2019 13:57

Backup&Restore and upgrade - both works well.

Post Reply