UZB Firmware Update from 5.07 to 5.27 fails

Discussions about Z-Way software and Z-Wave technology in general
stefxx
Posts: 5
Joined: 19 May 2018 21:58

Re: UZB Firmware Update from 5.07 to 5.27 fails

Post by stefxx » 08 Jul 2018 19:30

I also tried RC15. No difference, and I don't get that error. All versions (2.3.6, 2.3.7, 3.0.0RC14, 3.0.0R15) seems to update correctly, only to fail silently.

rafale77
Posts: 19
Joined: 23 Jun 2018 19:26

Re: UZB Firmware Update from 5.07 to 5.27 fails

Post by rafale77 » 13 Jul 2018 18:09

This is odd. Maybe the region change I forced through the URL is now causing a different error. Still no answer from PoltoS? Why are we having this problem?

Willem_K
Posts: 6
Joined: 09 May 2017 11:07

Re: UZB Firmware Update from 5.07 to 5.27 fails

Post by Willem_K » 19 Jul 2018 14:36

Same here on two UZB sticks. Solution from z-wave support would be appreciated.

User avatar
PoltoS
Posts: 4161
Joined: 26 Jan 2011 19:36

Re: UZB Firmware Update from 5.07 to 5.27 fails

Post by PoltoS » 21 Jul 2018 22:30

Please provide access to remote access and remote support. We will check my your case.

So please provide logs.

In PM

rafale77
Posts: 19
Joined: 23 Jun 2018 19:26

Re: UZB Firmware Update from 5.07 to 5.27 fails

Post by rafale77 » 27 Jul 2018 03:02

I am getting this strange error regardless of bootloader or firmware upgrade attempt

"Unable to update data. /ZWave.zway/ZMEBootloaderUpgrade"

"Unable to update data. /ZWave.zway/ZMEFirmwareUpgrade"

I tailed the logs and found nothing there when these error occur.

tail -f /var/log/z-way-server.log

I seem to have no problem communicating with the UZB stick and z-way working properly otherwise.

rafale77
Posts: 19
Joined: 23 Jun 2018 19:26

Re: UZB Firmware Update from 5.07 to 5.27 fails

Post by rafale77 » 28 Jul 2018 08:11

I made some progress and found out that there was a curl library issue with my installation of ubuntu. I downgraded the library and was able to upgrade from 5.07 to 5.23. In the process it wiped my license and set itself to JP region... this makes no sense. I was able to change the region back to US but because my license was broken, I thought I had a problem with my network and made the mistake of removing the zway from my network (I have other controllers)
Now the firmware update page is showing me bootloader 40196 is available but it continuously fails with this message after trying for a few seconds:

"Unable to update data. /ZWave.zway/ZMEBootloaderUpgrade"

The log shows this:

"[2018-07-27 22:02:07.651] [zway] Adding job: Start reflashing bootloader of Z-Wave.Me firmware for 5th generation Z-Wave chip
[2018-07-27 22:02:07.670] [D] [zway] SENDING: ( 01 04 00 F4 06 09 )
[2018-07-27 22:02:07.671] [D] [zway] RECEIVED ACK
[2018-07-27 22:02:08.899] [D] [zway] RECEIVED: ( 01 04 01 F4 01 0F )
[2018-07-27 22:02:08.900] [D] [zway] SENT ACK
[2018-07-27 22:02:08.900] [zway] Job 0xf4 (Start reflashing bootloader of Z-Wave.Me firmware for 5th generation Z-Wave chip): Wrong checksum
[2018-07-27 22:02:08.900] [D] [zway] Job 0xf4 (Start reflashing bootloader of Z-Wave.Me firmware for 5th generation Z-Wave chip): fail
[2018-07-27 22:02:08.900] [zway] Removing job: Start reflashing bootloader of Z-Wave.Me firmware for 5th generation Z-Wave chip
"

Why would I be getting wrong checksum? Note that I have tried to reinclude the UZB into my network and though it starts it, it never finishes. I am also getting a failure message after verifying my license. It passes the check but fails to upgrade capabilities although I can see a number of them got upgraded.

rafale77
Posts: 19
Joined: 23 Jun 2018 19:26

Re: UZB Firmware Update from 5.07 to 5.27 fails

Post by rafale77 » 28 Jul 2018 08:15

This is what I see when I try to upgrade apply the license

"[2018-07-27 22:14:03.950] [zway] Adding job: Get or set Z-Wave.Me firmware capabilities
[2018-07-27 22:14:03.959] [D] [zway] SENDING (cb 0x03): ( 01 34 00 F5 AF 30 8B 69 D1 4B 94 90 2D 66 60 51 CA 2B 99 B3 76 8A 80 42 FD 92 D7 7A 89 0F A9 A2 A3 8D EC C3 80 27 81 55 2A AA E6 9E BF F0 93 B8 2D 42 C1 4B 03 15 )
[2018-07-27 22:14:03.964] [D] [zway] RECEIVED ACK
[2018-07-27 22:14:03.969] [D] [zway] RECEIVED: ( 01 04 01 F5 CE C1 )
[2018-07-27 22:14:03.969] [D] [zway] SENT ACK
[2018-07-27 22:14:03.969] [zway] Job 0xf5 (Get or set Z-Wave.Me firmware capabilities): In progress
[2018-07-27 22:14:13.246] [D] [zway] RECEIVED: ( 01 05 00 F5 03 FA F6 )
[2018-07-27 22:14:13.247] [D] [zway] SENT ACK
[2018-07-27 22:14:13.247] [zway] Job 0xf5 (Get or set Z-Wave.Me firmware capabilities): Failed
[2018-07-27 22:14:13.247] [D] [zway] Job 0xf5 (Get or set Z-Wave.Me firmware capabilities): fail
[2018-07-27 22:14:13.247] [zway] Removing job: Get or set Z-Wave.Me firmware capabilities
[2018-07-27 22:14:17.019] [D] [zway] Job 0xf5: deleted from queue
[2018-07-27 22:14:17.020] [D] [zway] Job 0x3b: deleted from queue
"

User avatar
PoltoS
Posts: 4161
Joined: 26 Jan 2011 19:36

Re: UZB Firmware Update from 5.07 to 5.27 fails

Post by PoltoS » 31 Jul 2018 00:45

Please make sure to use latest Z-Way v2.3.7 or better v2.3.8-rc5

rafale77
Posts: 19
Joined: 23 Jun 2018 19:26

Re: UZB Firmware Update from 5.07 to 5.27 fails

Post by rafale77 » 31 Jul 2018 11:24

PoltoS, I will try but it seems right now that I have a licensing problem. My UZB might have lost something through the upgrades and now I am not able to enable the capabilities. Would 2.3.8 fix it?

rafale77
Posts: 19
Joined: 23 Jun 2018 19:26

Re: UZB Firmware Update from 5.07 to 5.27 fails

Post by rafale77 » 31 Jul 2018 11:39

Well I just tested 2.3.8 and the result is the same as 3.0.0 and 2.3.6. Exact same logs.

Post Reply