UZB Firmware Update from 5.07 to 5.27 fails

Discussions about Z-Way software and Z-Wave technology in general
schreibubi
Posts: 3
Joined: 29 Apr 2018 17:31

Re: UZB Firmware Update from 5.07 to 5.27 fails

Post by schreibubi » 05 Aug 2018 12:55

I just tried upgrading again using 3.0.0-rc15, but I'm still stuck at 5.07. I've attached the log-file, but can't see anything which sticks out.

Hope we can get this fixed!

Joerg
Attachments
z-way-server.txt.gz
Upgrade log
(325.61 KiB) Downloaded 24 times

User avatar
PoltoS
Posts: 4339
Joined: 26 Jan 2011 19:36

Re: UZB Firmware Update from 5.07 to 5.27 fails

Post by PoltoS » 05 Aug 2018 20:29

Please try with v2.3.8-rc5. It will work. On v3.0.0-rc15 another branch is used and the required patch is not yet merged.

Make sure to upgrade bootloader first.

stefxx
Posts: 8
Joined: 19 May 2018 21:58

Re: UZB Firmware Update from 5.07 to 5.27 fails

Post by stefxx » 12 Aug 2018 11:01

I just tried with 2.3.8rc5. Unfortunately the process doesn't even start now, but errors with this message:

Z-Wave Expert UI - ERROR
Unable to update data. /ZWave.zway/ZMEFirmwareUpgrade

Apart from upgrading to 2.3.8rc5 I don't recall making any other changes...

User avatar
PoltoS
Posts: 4339
Joined: 26 Jan 2011 19:36

Re: UZB Firmware Update from 5.07 to 5.27 fails

Post by PoltoS » 16 Aug 2018 00:52

Can you send in PM remote access credentials or provide logs? This looks strange

stefxx
Posts: 8
Joined: 19 May 2018 21:58

Re: UZB Firmware Update from 5.07 to 5.27 fails

Post by stefxx » 03 Sep 2018 21:37

With the help of PoltoS, I was finally able to upgrade to 5.27! According to PoltoS: "there is some dependencies problem in Jessie with conflicting libraries and currently http requests are not supported."

Upgrading to Stretch resolved this issue. Thanks!

steinis
Posts: 22
Joined: 13 Aug 2015 09:34

Re: UZB Firmware Update from 5.07 to 5.27 fails

Post by steinis » 04 Sep 2018 14:07

stefxx wrote:
12 Aug 2018 11:01
I just tried with 2.3.8rc5. Unfortunately the process doesn't even start now, but errors with this message:

Z-Wave Expert UI - ERROR
Unable to update data. /ZWave.zway/ZMEFirmwareUpgrade

Apart from upgrading to 2.3.8rc5 I don't recall making any other changes...
Did you find a solution? I have the same error as you after upgrading.

Also after upgrading to v2.3.8-rc5 my MQTT plugin stop sending out message(responding to received message is stil working)

stefxx
Posts: 8
Joined: 19 May 2018 21:58

Re: UZB Firmware Update from 5.07 to 5.27 fails

Post by stefxx » 05 Sep 2018 18:20

See the post above yours. Upgrade to Stretch is the solution.

steinis
Posts: 22
Joined: 13 Aug 2015 09:34

Re: UZB Firmware Update from 5.07 to 5.27 fails

Post by steinis » 05 Sep 2018 19:01

OK thanks. How do I do this I have only downloaded the image from z-way and installed it on a rpi.

stefxx
Posts: 8
Joined: 19 May 2018 21:58

Re: UZB Firmware Update from 5.07 to 5.27 fails

Post by stefxx » 05 Sep 2018 21:20


steinis
Posts: 22
Joined: 13 Aug 2015 09:34

Re: UZB Firmware Update from 5.07 to 5.27 fails

Post by steinis » 05 Sep 2018 22:52

ahh that completely crashed my system, did you update to Stretch after upgrading to V2.3.8-rc5?
Under the installation of Stretch you have to answer some question to replace or keep some config files. What did you pick?

Post Reply