Disable WAKEUP_NO_MORE_INFORMATION ?

Discussions about Z-Way software and Z-Wave technology in general
Post Reply
brianaker
Posts: 24
Joined: 11 Nov 2016 16:57

Disable WAKEUP_NO_MORE_INFORMATION ?

Post by brianaker » 13 Sep 2018 01:34

Is it possible to disable the sending of WAKEUP_NO_MORE_INFORMATION ?

User avatar
PoltoS
Posts: 4251
Joined: 26 Jan 2011 19:36

Re: Disable WAKEUP_NO_MORE_INFORMATION ?

Post by PoltoS » 14 Sep 2018 11:36

No. This is a must by protocol. But you can make Wakeup time very big

brianaker
Posts: 24
Joined: 11 Nov 2016 16:57

Re: Disable WAKEUP_NO_MORE_INFORMATION ?

Post by brianaker » 16 Sep 2018 00:22

How do you set the time to delay WAKEUP_NO_MORE_INFORMATION? I see how to set the WakeupInterval, but I don't believe that what you are suggesting.
Thanks!

User avatar
PoltoS
Posts: 4251
Joined: 26 Jan 2011 19:36

Re: Disable WAKEUP_NO_MORE_INFORMATION ?

Post by PoltoS » 16 Sep 2018 08:43

Wake-up Interval is governing this. Why don't you believe?

brianaker
Posts: 24
Joined: 11 Nov 2016 16:57

Re: Disable WAKEUP_NO_MORE_INFORMATION ?

Post by brianaker » 17 Sep 2018 03:06

Sorry, let me better explain what I am asking.

Z-way-server by default sets Wake-up Interval to 3600 ( or if 0 it sets it to devices default ).

The device will then wake up based on whatever the value is.

After the device wakes up, the z-way-server will send a packet to the z-way-server ( assuming it is set to be the controller to receive the wake up; else if no controller is set a broadcast wake up is sent ).

Z-way-server upon receiving the wake up will then send a 'No More Info' notification to the node ( which the node should interpret as " go back to sleep until next event/interval ").

The "no more info" packet is what I am suggesting should be configurable; the specification does not require that the "no more" packet be sent immediately, or at all, it is just suggested.

User avatar
PoltoS
Posts: 4251
Joined: 26 Jan 2011 19:36

Re: Disable WAKEUP_NO_MORE_INFORMATION ?

Post by PoltoS » 19 Sep 2018 23:51

It is suggested to send this. You can set in z-way devices[N].data.keepAwake=true to prevent this

Post Reply