does not work.

Discussions about Z-Way software and Z-Wave technology in general
Post Reply
Posts: 6
Joined: 08 Sep 2019 15:36 does not work.

Post by xtrnisse » 09 Sep 2019 20:56


I'm quite new to all this, so please bare with me a bit...

I set up a RazberryPi (with Stretch) about a week ago, which at the comfort of my own home, worked like a charm. I could connect both locally and remote using both the Android app and the web interface through

I then powered it all down and moved all the stuff (WiFi router, Pi and z-wave units) to my summer house to set it up there. I could connect locally at the new location as well to verify that the Pi and Z-way module was up and running, and based on a few rules, controlling a few heating fans based on the reading from a couple of temperature sensors.
But... I never got it working with the remote connection.

The android app says that the hub isn't connected, and when I try logging in at I either get "Backend server error" or it just returns me to the same login page over and over again...

Does anyone know why this might be? Do you need any additional info to be able to troubleshoot?

Best regards
Last edited by xtrnisse on 10 Sep 2019 07:54, edited 1 time in total.

Posts: 87
Joined: 09 Oct 2016 15:24

Re: does not work.

Post by IgoriokLT » 09 Sep 2019 22:35

try cleaning browser cache and cookies.

Posts: 6
Joined: 08 Sep 2019 15:36

Re: does not work.

Post by xtrnisse » 10 Sep 2019 07:55

Tried that, didn't work.
How would that be relevant to the app not connecting? ☺️

Posts: 87
Joined: 09 Oct 2016 15:24

Re: does not work.

Post by IgoriokLT » 10 Sep 2019 08:39

Do you have remote access enabled? Another thing you can try to do is forward port 8083 on you router, allowing direct connection to your server from the outside of your network.

Posts: 106
Joined: 07 Feb 2016 16:29

Re: does not work.

Post by micky1500 » 10 Sep 2019 15:22

I don't know the answer, but I would take a look at these :-

If it was working before you moved it !
unlikely, But check 'Management'-'Remote Access' Is it enabled and with the same Access ID you are using?

You say 'WiFi router' Is that the same router with Your Internet WAN connection ?
or maybe wifi repeater.

Login to the raspberry with Telnet/SSH
Try pinging one of the z-way servers. ping
The server does respond to ping, I just tried it. (64 bytes from icmp_seq=1 ttl=51 time=41.7 ms)

also try the command netstat -n
scroll up and you should see an Active connection to port 22. Your local ip address, connected to port :22 of a Z-Way server.

Hope this is some help.
Raspi 4(Buster), Zwave Version 3.0.4

Posts: 6
Joined: 08 Sep 2019 15:36

Re: does not work.

Post by xtrnisse » 10 Sep 2019 22:49

As I'm not at the my summer house right now (will be back in 2 weeks) I can't check right at this moment, but I did check a bunch of stuff before i left.

1. Remote access is enabled, even the remote access support function is enabled.
2. The Access ID is the same (141713).
3. The WiFi router that the Pi is connecting to is actually a 4G WiFi Hotspot (Huawei E5573CS) as the summer house (a little cottage in the woods) does not have any tethered connection to the outside world, so i can't do port forwarding unfortunately... However, I didn't have to do that when i set it up either, so that shouldn't be an issue, even if i understand it would have been beneficial.

4. I will try pinging one if the z-way servers when I'm back there...
5. I'll also try the netstat -n command. If a connection is established (or not), what does that mean?

How does all this explain these messages I'm getting when I'm trying to log in?
Capture.PNG (16.24 KiB) Viewed 1127 times

Posts: 11
Joined: 28 Mar 2018 20:17

Re: does not work.

Post by otverber » 14 Sep 2019 00:14

is the ip adress identical on the two networks?
I read somewhere that zbox uses the local ip to log in from remote...

Post Reply