UZB broken?

Discussions about Z-Way software and Z-Wave technology in general
Post Reply
Jeppe
Posts: 3
Joined: 25 Oct 2019 15:18

UZB broken?

Post by Jeppe » 25 Oct 2019 15:24

I was getting problems with my UZB connecting some devices, so I thought I would try to update it to newest bootloader and firmware.

I used the updater tool to do the update under Ubuntu 16.04. But after flashing it seems like I cannot pair anything to the dongle. It just errors on everything.
My goal is/was to get it to UZB/5.26/40196 as it seems like that is most recent version here: https://service.z-wave.me/expertui/uzb- ... tml?hw=277

The command, result and complete log can be found here: https://pastebin.com/nkiE3h6y

I did try Z-Way 3.0.0 for updating also, but only bootloader is visible here and everytime I try to upgrade I get a CRC error.

Any clues on what the problem is?

Jeppe
Posts: 3
Joined: 25 Oct 2019 15:18

Re: UZB broken?

Post by Jeppe » 29 Oct 2019 15:05

As a side note I also tried with Z-Way 3.0.0.
In the firmware update section I can see the bootloader 40196 update for 5.23.

Z-Way show this: Unable to update data. /ZWave.zway/ZMEBootloaderUpgrade

Log shows this:

Code: Select all

[2019-10-28 08:55:10.255] [I] [zway] Adding job: Start reflashing bootloader of Z-Wave.Me firmware for 5th generation Z-Wave chip 
[2019-10-28 08:55:10.265] [D] [zway] SENDING: ( 01 04 00 F4 06 09 ) 
[2019-10-28 08:55:10.266] [D] [zway] RECEIVED ACK 
[2019-10-28 08:55:10.398] [D] [zway] Job 0xf4: deleted from queue 
[2019-10-28 08:55:11.492] [D] [zway] RECEIVED: ( 01 04 01 F4 01 0F ) 
[2019-10-28 08:55:11.493] [D] [zway] SENT ACK 
[2019-10-28 08:55:11.493] [I] [zway] Job 0xf4 (Start reflashing bootloader of Z-Wave.Me firmware for 5th generation Z-Wave chip): Wrong checksum 
[2019-10-28 08:55:11.493] [D] [zway] Job 0xf4 (Start reflashing bootloader of Z-Wave.Me firmware for 5th generation Z-Wave chip): fail 
[2019-10-28 08:55:11.493] [I] [zway] Removing job: Start reflashing bootloader of Z-Wave.Me firmware for 5th generation Z-Wave chip | Version number: v3.0.0 | UI version: 1.5.0 | Built date: 18-07-2019 01:48:51

User avatar
PoltoS
Posts: 5053
Joined: 26 Jan 2011 19:36

Re: UZB broken?

Post by PoltoS » 29 Oct 2019 23:56

This is very strange and means that the firmware is refusing the upgrade file due to CRC error. Means your UZB has a broken EEPROM or some other fault.

Jeppe
Posts: 3
Joined: 25 Oct 2019 15:18

Re: UZB broken?

Post by Jeppe » 30 Oct 2019 09:17

PoltoS wrote:
29 Oct 2019 23:56
This is very strange and means that the firmware is refusing the upgrade file due to CRC error. Means your UZB has a broken EEPROM or some other fault.
Does that mean the device is broken or can we force upgrade it or something like that?

User avatar
PoltoS
Posts: 5053
Joined: 26 Jan 2011 19:36

Re: UZB broken?

Post by PoltoS » 07 Nov 2019 03:09

We can not force upgrade ;( I believe it is faulty.

Post Reply